
Training Manual
for Windows Users

RagTime GmbH

R A G T I M E   
® 5

the professional

solution
Business Publishing

RagTime Solo must not be used commercially.



Internet: <http://www.ragtime-online.com>

E-mail: <mailto://info@ragtime.de>

RagTime is a trademark of RagTime GmbH.

All other trademarks belong to their holders.

© 1996-2001 RagTime GmbH. All rights reserved.

This manual was written by Peter W. Duy, Jens F. Adam, Georg Jünger and

Monika van Lück.

It was translated from German to English by Stephen Lindenmayer and

Olu Taylor.

The layout was designed by H. Erich Frass and Jens F. Adam using Meta

fonts (Erik Spiekermann, FontShop). Special characters and key symbols

are set in Zapf Dingbats (Hermann Zapf, International Typeface

Corporation), Prestige 12 Pitch (Bitstream Inc), Zeal (The Font Bureau)

and Hilden 95 (Jens F. Adam, RagTime GmbH).

Version 5.6 EUS



1

Overview
RagTime 5 Documentation b

Contents b Typographic Conventions



Overview4
The RagTime 5 documentation consists of several parts on various

media:

> About RagTime (printed and as a PDF document) 

Installation and configuration information along with an overview of

the philosophy and concepts behind RagTime 5. Please install

RagTime 5 before reading the documentation. It helps to work through

instructions on your PC as you read along.

> this Training Manual (printed and as a PDF document) 

Includes 8 exercises in 3 steps for newcomers to RagTime 5

> RagTime 5 Reference (printed, on screen and as PDF document) 

Includes overviews, information on documents and components, and

doubles as a reference for all menus, commands, tools, windows,

dialog information and boxes. 

> Formulas and Functions (on screen and as a PDF document) 

Describes and provides examples of mathematical functions and

operations.

> RagTime 5 for RagTime 3 Users (PDF document and on screen) 

Explains the differences between RagTime 3 and RagTime 5.

The on-screen documentation is installed together with the

program. It is intended for reference and contains detailed information

on commands, features, functions, and so on. All topics are interlinked

via cross references, and there are numerous search capabilities

including an index, lists of commands and functions, and a full-text

search tool.

Except for the Training Manual, which is available in two versions,

the RagTime 5 documentation is suited for Z Microsoft Windows and

z MacOS users alike. The few differences that do exist are flagged with

the afore-used symbols.

Please first install RagTime 5 on your computer and then begin

reading the documentation. It always makes sense to try out what you

have just read.

The following is an overview of the contents of each chapter in the

training manual. You can also see in this list what is done in each

exercise, in case you are looking for a particular procedure or want to get

ideas for your own document.

1 OVERVIEW
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This manual uses the following typographic conventions when

formatting text.

Standard Text Style The style to describe RagTime and its properties

Formula Style The style for formulas and cell addresses

COMMAND STYLE This is the style applied to commands, keys,

menu descriptions and dialog headers. Menu

descriptions such as format>style>bold

indicate layered menus whose menu items are

called up in sequence.

 When this symbol appears on the right page, it

denotes comments especially directed to

beginners. On the left-hand side, you will find

alternative solutions at the same user level,

pointers on familiarizing yourself with the pro-

gram, alerts, and references to other topics

within the Training Manual. If you have little

experience in computers and sophisticated com-

puter programs, it makes sense to read the infor-

mation provided for beginners.

Since we do not expect you to read this manual

cover to cover, you may find similar pointers in

several places.

When this symbol appears on the right page, it

denotes comments especially directed to ad-

vanced users. These pointers present solutions

to complex tasks and include procedures and

comments required to handle sophisticated

documents. Those readers who are less

advanced should wait to read these comments

until they have become more familiar with

RagTime.

Since we do not expect you to read this manual

cover to cover, you may find similar pointers in

several places.

Overview8
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nter key
Whom This Training Is For
This training is intended to give the novice a straightforward

introduction to the basics of RagTime 5. However, you will benefit most

from working through the exercises if you are familiar with standard PC

operations. If you need to learn these basic skills, the following

possibilities are available:

> Many windows-based PCs are shipped with short introductory

documentation and tutorials in print and on CD. Current releases include

�Introducing Microsoft Windows 98� on CD and the booklet entitled

�Introducing Microsoft Windows 95.� We recommend that you read these

or other available Windows-related publications to become acquainted

with the basics of the operating system. To gain a basic understandings

of the ins and outs of Windows, the most well suited chapters are

�Introducing Windows 98� on the �Microsoft Windows 98 Start� CD and

the chapters on the Program Manager, File Manager/Windows Explorer

and printing in the �Introducing Microsoft Windows 95� book.

Little effort is required and the results are of great use. 

In this way, you can gain the following essential knowledge and

skills:

You Know the Names and Uses of the Most Important Keys�

The keyboard layout displayed here may differ from the keyboard

you�re actually using.

2 INTRODUCTION

 Tab key t

 Caps Lock key 

Shift key s

E

Alt key Arrow keys4 6 8 2
Windows key

Ctrl key Return key r

Esc key Function keys A - L Delete key

Alt Gr key



You Know Your Way around the Desktop When You Can�
> differentiate among the various objects on the electronic desktop

(program, file, folder and desktop icons),

> identify which window, program or other object is active; and

> open and close windows or minimize, maximize or restore them to

suit your needs.

You Know How to Use the Mouse When You�
> can select and move objects on the electronic desktop (#),

> know what a click (') and a double click (") do,

> can differentiate between functions assigned to the left and right

mouse buttons,

> can select a command from a menu (Y),

> can start and end a program,

> are able to open and close windows. 

You Can Navigate in the Windows Operating System When You�
> can switch among several programs using the task bar,

> know how to name files (d documents),

> know how to select a folder (f) in which you want to save a

document,

> are able to find and open files from the File Manager or Windows

Explorer and from a program,

> can print the results of your work.

It would also be advantageous if you are familiar with word

processing.

What to Expect: the Value of the Training Manual
Chapters 4, 5, and 6 comprise the main part of the training. In these

chapters, you are introduced to practical work with RagTime 5 (more

about this in chapter 3)

The Left and Right Pages
A special feature of chapters 4 through 6 is the difference in the

content of the left and right pages.

The actual exercises, which appear on the left pages, are intended

for RagTime novices in particular and treat basic material, or an

�essential curriculum.�

The right pages do not have a rigid structure, but are oriented to the

facing pages and complement them. They contain two different kinds of

comments that should help you gain a firmer command of the program.

You Know Your Way around the Desktop When You Can� 11



< All steps are con-
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The Structure of the Exercises12
> Summary

> Supplements flagged with a B are primarily targeted toward

providing newcomers without a background in comparable

programs with alternative solutions to those presented on the left

along with tips and tricks to make life easier.

> Notes flagged with an A are targeted toward advanced users who

have in-depth knowledge of RagTime and similar programs and are

interested in solving complex problems immediately.

The Structure of the Exercises
The individual exercises are structured as follows: First, the most

important goals that you should achieve in the exercise are presented.

Also, an illustration of the result of the exercise is provided with com-

ments. This should give you an impression of what lies ahead so that you

can better keep the goals in mind.

Next comes the actual exercise. You will work through a problem in

steps, which are very detailed in the initial exercises. The exercises are

intentionally structured to leave you freedom in shaping the example.

Please note that although an exercise is divided into a number of

sections, the steps are numbered consecutively throughout the entire

exercise.

Each chapter ends with a summary of material introduced in the

chapter. Chapter 7 provides a summary including the main points of the

exercises, and illustrations and overviews elucidating important pro-

cedures used in working with RagTime 5. The conclusion suggests ways

to continue learning about RagTime.

Before You Start: What You Should Know about RagTime
RagTime is an integrated office application program developed in

Europe. It made its premiére before a large, enthusiastic audience at the

Hanover CeBIT trade fair in 1986. From the start, RagTime was conceived

as a multilingual program, so there were soon versions in many Euro-

pean languages. In 1999, RagTime was ported to Windows and has since

been available to both Windows and Macintosh users.

The key features of RagTime are the different types of components

in a single document and their display on pages. What does this mean?

Imagine that you are sitting at your desk with a blank sheet of paper in

front of you. Being a creative person armed with all sorts of tools, you

can conjure up various things on the paper.

They might be texts in all imaginable forms. You can draw diverse

forms on the paper. You can perform highly complex calculations and

represent the results in three-dimensional graphs. You can also paste

pictures here and there and write captions for them. Probably you have

> Doing the exercise

> Description and
illustration of the goal
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> Erxtensions

selected your writing, drawing or calculating tools not to limit but to

support your imagination. In any case, you naturally assume that you can

put anything on the paper lying before you. And that is exactly what

RagTime can do�put everything on one page, in one document, with

one program. You don�t have to worry about different file types or decide

prematurely whether text, spreadsheets or layouts are most important

for you in a document. All components are treated equally and may be

combined in nearly any fashion. You can choose from a variety of output

possibilities. RagTime allows you to send jobs to an inkjet or laser prin-

ter, expose color-separated documents for offset printing, export files in

full or in part into Acrobat PDF, EPS or�for the Internet�HTML format.

What makes these different output options possible are the soft-

ware�s integrated components (word processor, spreadsheet, etc.) which

you can use as you would stand-alone programs. However, you can also

join the components in a variety of ways. For example, a result from a

spreadsheet may be used in a text so that the text is automatically modi-

fied to reflect changes in the spreadsheet. You can install components in

a layout to include different sorts of data on one page.

You can also install components in spreadsheet cells or as �flowing

objects� in a text. All this can be done, if well planned, when you begin

working on a document, or later, when the requirements of a document

become clearer or are completely revised.

Extensions and Cooperation with Other Programs
Most daily office routines can be performed with RagTime 5. But

when you need a solution that was not anticipated in the spectrum of

RagTime �s features, we offer numerous possibilities for extensions and

interfaces to other applications.

RagTime may be extended nearly without limit. Graphs and poly-

gons are examples of extensions. Certain third-party extensions are

available, e.g RagTime Connect (links RagTime to databases) and

SlideTime, a presentation program. Documents created in RagTime 3 or 4

for Mac OS or RagTime 5 can be used under RagTime 5.5 for Windows.

Please refer to the �Read Me� file on your installation CD for further in-

formation.

Another of RagTime�s strong points is its variety of import and ex-

port capabilities. RagTime documents can be linked to SQL databases

and other programs with built-in ODBC support using ODBC middleware.

Filters currently available are listed in the following table.



Built-in and external converters modify various data formats, if

necessary, so that RagTime can use them.

RagTime has versatile import and export features, allowing one to

repeatedly use data that exist in only one place in the computer. Conver-

ters supplied with RagTime can read and write files in the following for-

mats: Microsoft Excel, Word, EPS, PDF, RTF (Rich Text File), SYLK, XTND,

PICT2, and Text. 

Various picture formats can be imported, i.e., EPS, different TIFF for-

mats, JPEG, PNG, BMP, PICT2 and DCS.

Extensions and Cooperation with Other Programs14

> Import and export

Data Export 

MS Word 6.0

MS Word 4.0-5.1 (Mac)

Unicode

EMF/WMF

HTML etc. via converters
supplied with RagTime 5

Program Extensions
for RagTime 5

e.g.
Graphs and polygons

Others are being
developed

Data Import
MS Word 2.0/6.0/95/

97/2000
MS Word 4.0-5.1 (Mac)

RTF, Unicode, dBase 
Excel Spreadsheets

via converters
supplied with RagTime

Data Import from
Excel Spreadsheets

Picture Import of All
Standard Formats

TIFF, EPS, BMP, JPEG

also from picture
databases, including

Cumulus

➡
✄
❚✄
➡

➡➡➡➡➡➡➡➡➡➡
➡✄
✄
➡

Scanning

via

TWAIN adapters

Dynamic links 

to SQL-databases

via

RagTime Connect and

ODBC

File Exchange with
Many Popular

Programs

via
Drag & Drop, or the

Clipboard
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The time spent on a 
document may be 

estimated with the 
following formula:

 time=[(Cot +Crt)R]P
ot = Conception time

Crt = Creation time
R = Revision factor

 Personal perfection
factor

3 LEARNING RAGTIME IN THREE STEPS

How RagTime Supports You
Friends told you about the special features of a new program.

Besides that, you read a promising magazine article about the

capabilities of the program and consequently bought it from your dealer.

Now, as it is on every Friday, a mountain of unanswered business

letters are lying in your �To Do� basket. With great expectations, you

start the program and�you are thunderstruck by the view of

multitudinous buttons and functions. Just �winging it� seems hopeless to

you. Training must wait.

So, get out the typewriter and�

The training provided here should save you from such a situation.

That�s why we ask�

How Much Time Do You Have?
If you have already been working with computers a while, you know

that the total time expended to finish one document is the sum of

(among other things) the time needed to create the document and the

time needed to revise it�and you always have to revise.

The more time you take to plan a document, the greater the chance

that the effort to revise the document is minimal�if the program

supports you in this respect. And RagTime does. Consequently, this

training manual introduces RagTime to you in three steps (chapters 4, 5,

and 6) based on the amount of time you have to plan a document.

Three Steps to RagTime
> The exercises 1 through 4 (in chapter 4) are especially intended for

the cases in which you need fast results. They are directed toward the

hurried user with no RagTime experience, who wants a quick

introduction and for whom the revision time required for the document is

of secondary importance.

> The exercises 5 and 6 (in chapter 5) require somewhat more time for

the conception of the document. RagTime rewards this expenditure with

increased comfort when you later use and revise the document.

> In the concluding exercises 7 and 8 (in chapter 6), two projects are

presented for which it is worthwhile to spend more time on planning and

design. With these two exercises, we want to give you a few suggestions

about how to continue.

This training manual leaves it for you to decide how perfect the

documents you create are in form and content. The multitude of layout

features that the program offers is sure to surprise you. The on-screen

help will provide further stimulus.
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We don�t have the ambition in this training manual to familiarize you

with all of RagTime�s features and variations in one giant leap. But the

first small steps are the most important. For this reason, the examples

are intentionally kept simple. Mastering the program takes some time.

The RagTime novice should in any case take the three steps in order.

The practiced RagTime user, on the other hand, can skip parts of the

training without problem and turn directly to, for example, chapter 6.

Step One: RagTime Fast
�Fast� documents are, for example, the letter that has to go out

now, or the bid that the customer is waiting for. They are model cases for

so-called �one-page� documents.

Situation: You don�t have a form available but you must, for

example,

> write a letter quickly,

> compose a memo in a hurry,

> calculate a bid right now,

> perform a one-time-only statistical evaluation.

Recommendation: chapter 4 - the one-page RagTime document

> 4.1 How to create a one-page document

> 4.2 A simple business letter

> 4.3 A simple spreadsheet

> 4.4 Sales department statistics

> 4.5 A package design

A one-page document is the right choice when quick solutions

without much planning are needed in �hard copy.� Since changes are, as

a rule, time consuming, they should only be used in one-time-only cases

like those described.

One-page documents are particularly appropriate for getting a first,

quick grip on the program because they are uncomplicated and generally

have a simple layout.
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Step Two: RagTime Well Planned
Forms which you frequently use should be well thought out, since

changes in them are generally undesirable. Typical cases for this

category of documents are business letters for extensive bids, forms for

comparing bids and, not to be forgotten, forms for invoices and requests

for payment.

Chapter 5, devoted to documents from this group, focuses on using

RagTime stationery pads. Stationery pads are generally highly structured

documents which are always used in the same form. They are

comparable to a pad of forms from which pages are torn as needed.

Stationery pads have always been RagTime�s special territory.

Situation: You need uniformly designed, reusable forms which are

subject to minor changes, for example, for

> business letters of several pages,

> spreadsheet calculations,

> invoice forms.

Recommendation: chapter 5 - the RagTime stationery pad

> 5.1 How to create a RagTime stationery pad

> 5.2 A business letter of several pages

> 5.3 A simple invoice

Step Three: RagTime Professional
Extensive documents with a layout containing various elements

have their perils. Keeping an eye on them requires long experience.

In practice, just such documents must be updated frequently.

Changes must be made in both the form and the content of the

document. Some changes affect the entire document while others affect

only single parts. To fulfill these demands, RagTime provides you with

master pages.

Master pages are templates for a document of arbitrary structure

and their potential goes far beyond the RagTime stationery pads (chapter

5). The document may be seen as an electronic copy of the master pages.

Changes in the master pages are made immediately in the dependent

document. This dynamic connection between the two substantially

simplifies necessary changes and saves time. As you become more

experienced in using RagTime, you will learn to appreciate this feature.
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Situation: You need complex documents which are subject to

frequent changes, for example,

> price lists,

> catalogs and advertising brochures,

> planning documents (flow charts, organizational charts, and

so on),

> documents for company training,

> technical instructions and descriptions.

Recommendation: chapter 6 - the RagTime master layout

> 6.1 How to create a RagTime master layout

> 6.2 A price list in a spreadsheet

> 6.3 Training documents



Step Three: RagTime Professional20



4

Step One:
RagTime Fast

Creating a One-Page Document b Exercise 1: Business Letters Made

Easy b Exercise 2: RagTime Does Your Calculations b Exercise 3:

Success in the Sales Department b Exercise 4: Packaging Sells

Products�Designing a Package b Highlights from This Chapter



Creating a One-Page Document22
4.1 Creating a One-Page Document

This section describes how to start RagTime, how the screen looks

initially and how the various elements that you see work.

You will start the on-screen help program and learn to use it. You

will learn to differentiate between containers and components and to

work with them.

You will use various containers and discover their role in our

concept, �everything on one page.�

Starting RagTime
There are many ways to start RagTime. A frequently used option is

to launch RagTime using the Start button. To do so, click  Start and

select RagTime by unclustering the following menus: Start>

Programs>RagTime. RagTime will start as soon as you release the

mouse button when the pointer is above the RagTime menu item. By the

way, to facilitate navigating, the last menu will include the RagTime icon

shown on the left beside the �RagTime� entry.  Please refer to the facing

page for other ways to start RagTime. We�re sure you�ll soon pick your

favored method and stick with it.

What You See
The RagTime program environment will appear shortly after you

start RagTime. The key elements from top to bottom are:

> The blue title bar displaying the program�s name, �RagTime 5.0,�

and the new document�s preliminary name �Untitled 1, Layout 1.�

> Underneath you will find the menu bar. You will recognize the first

two items on the menu, File and Edit, as well as Info, from other

Windows programs.

The other menus, Format and so on, belong to RagTime, although

the menus File and Edit also include a few RagTime commands which we

will come back to later.

> Below the menu bar, you will find a tool bar that houses a number of

buttons. We will revisit them in more detail later on as well.

> The fourth part, below the menu and tool bars, is the actual

RagTime window. You will find some familiar elements here as well as

some requiring explanation.

Goals

4 STEP ONE: RAGTIME FAST



Creating a One-Page Document 23  �  Notes
B Other ways of starting RagTime:
> Program alias on the desktop

Using the Windows Explorer, drag the RagTime program icon from the

�RagTime� folder onto the desktop. You have just created an alias, i.e., a

link to the program icon on your desktop. Aliases can be identified by the

small arrow in the bottom left-hand corner of the icon. To start RagTime,

simply double-click this icon.

> Alias in the �Startup� folder

In the Windows Explorer, click on the RagTime program icon located in

the �RagTime� folder with your right mouse button and select Copy.

Then, locate the following folder: C:\Windows\Startmenu\Startup. Click

the Autostart folder icon with your right mouse button and select Insert.

You have just added an alias to your Startup folder that will cause

RagTime to start every time you boot up your Windows system.

Keep an eye on the menu bar when working with RagTime 5. It

contains the standard menus and, next to the format menu, one which

changes according to the circumstances.

Like the menu bar, the tool bar contains some commands that are

always available as well as others which change according to the

circumstances.
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In the top right-hand corner, you will find the typical fields to

Minimize, Maximize, and Close windows that also apply to the

document we�re working on. The window�s bottom and right borders end

in scroll bars. Other standard elements are described in your Windows

documentation.

RagTime elements include the rulers along the left and top edges.

The illustration shows them in inches. The portion of the ruler that you

see depends on the size of the screen and selected paper format�here,

a US letter-size page appears in the illustration. 

On top of the long scroll bar in the right border, you will find

buttons you can use to jump from page to page. The buttons have

triangles pointing up (page back) and down (page forward).  They frame

a small box indicating the number of the active page, which is page 1 in

our example. The page number is also shown on the tag at top-left.

The layout window depicts a page of paper which you can now

design as you wish. The dotted line appearing on the page indicates the

printable range. The printable area may be larger or smaller, depending

on your printer. Anything outside the dotted line will not be printed!

Men
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Page

Top 

Page

first 

Page

area

Bord

print

(prin

Left 

Stan

Printable area >
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B When launched, RagTime 5 always attempts to recreate the

conditions prevailing when the program was last quit. If this is not the

first start of the program, it may appear differently on your screen.

B The illustration on the adjacent page is from a portrait monitor. The

window may look different on your screen, depending on its size and

configuration.

The size and appearance of the window displaying a paper page

also varies depending on the selected orientation (portrait or landscape)

and the monitor scaling set in the Window>Display Scale menu (10%-

800%).

B Go to page...

Double-clicking on the page indicator between the triangles in the right

scroll bar reveals a dialog box you can use to jump to a specific page. Try

it out once you have created a document with multiple pages! (Once a

document contains several layouts, you will realize that the program will

only let you jump around within the active layout�more on this in a bit.)
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Select

Edit curve
The layout window also contains an active rectangle which is used

to display new documents in its default setting. It is immediately

available for entering text as soon as a new document is created.

However, you can tell RagTime to change its functionality if you wish.

On-Screen Help
Should you become stuck, RagTime offers two sorts of immediate

help. For example, if you don�t remember exactly what one of the

elements does, then place your pointer on top of the program

component (tool,  tear-off menu, etc.) and leave it there until a small

yellow field appears. It will display the name of the program element.

Detailed information on RagTimes� full range of features is available

under Info>Reference. Here you will find RagTime�s complete on-

screen manual in which all aspects of the program are discussed in

detail. The entries are all cross-referenced via links so you can quickly

access related information. It pays to take advantage of this handy

feature especially while getting acquainted with RagTime. The Info menu

also provides access to books that address other aspects of RagTime.

Please refer to the adjacent page for additional information on our on-

screen help.

The Tool Bar
Before you get your first practical experience with RagTime, we will

briefly introduce the most important tools, available in the tool bar, for

working with layouts and drawings.

Drawing Rectangles
To obtain an empty page, delete the existing

active rectangle by pressing the Delete key.

1. Select the rectangle tool by clicking the icon in the tool bar once.

Notice that the pointer changes its form to crosshair when you move it 

back over the page.

ion tool

Rounded rectangle

Sector
Oval

Arc

Rectangle

Polygon

Graphic text
Bézier curve

Regular polygon

Straight line

Horizontal pipeline

Cut pipeline

Vertical pipeline
Magnifying glass

content type
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B / A If you are using several printers or a printer and a fax modem,

RagTime 5 always shows the printable area of the currently selected

printer. You can choose another printer in the Start>Settings>

Printer menu.

B / A RagTime�s on-screen documentation is divided into several

electronic books which you can access via Info>Reference, etc. The

documentation includes for example:

> Reference. Contains a comprehensive explanation of RagTime�s full

range of capabilities and features. Recommended for basic users as a

supplement to this Training Manual from time to time to learn about

some more of RagTime�s capabilities and how to make use of them.

>Formulas and Functions. Interesting to RagTime users who would

like to learn to use mathematical, layout, button and standard functions.

> Printing HTML. Contains notes on the HTML output generated by

RagTime documents. Primarily suitable for advanced users.

The on-screen help is divided into chapters marked with a book icon

and sections on individual topics flagged with a question mark.  These

electronic books feature panels with search aides and color-coded

hyperlinks included directly in the text that you can use to navigate

through the help. These electronic cross references give you instant

access to additional information on a certain topic.

Please note that full text searches are also possible.

Please refer to your Windows documentation for additional

information on the basics of the on-screen help.

B You can do two things with the Content Type tool. It can be used to

determine the type of content to be included in a rectangle or other

container. Additionally, it doubles as an indicator to determine the type

of content included in a selected object if you�re uncertain of its content.
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2. Drag, that is, click and move the crosshair pointer while holding

down the mouse button, diagonally across the page and release the

button.

The following rectangle

becomes visible.

What has happened? You have just created your first drawing

object. Just as you drew a rectangle with the rectangle tool in this

example, you can create other objects, for example, ovals, sectors,

arcs or lines, with the appropriate tools.

What was the point of this? However simple it may be, you have

created a drawing on a page of a layout.

In RagTime, not only can you draw objects, you can fill the drawing

objects with contents such as texts or pictures, converting the objects to

containers.

A container is any object which contains a component, such as a

text, a picture, and so on.

Selecting and Moving Drawing Objects
The object which you just drew has eight �handles,� providing that

you have not clicked elsewhere after releasing the mouse button.

When these handles are visible, you can manipulate the object in

various ways.

 Container >
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A Many tools are built into RagTime 5, while others may be installed as

external extensions. Therefore, the tool bar may contain more or fewer

tools than shown in the illustration. The tool for drawing regular

polygons, for example, is an external extension. If you want to

experiment, you can remove it from the folder �Extensions�, restart

RagTime 5 and check the tool bar.

A If you hold the s key while dragging open a rectangle, it will become

a square. The s key has the same limiting effect when used in

conjunction with other tools in the same manner.
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3. First practice selecting and deselecting an object.

If the handles are visible, click somewhere just outside the dotted

lines, so that the handles disappear.

To select the object again, move the pointer, this time without

pressing the mouse button, somewhere inside the rectangle. Notice that

the pointer changes its form. The result should look something like this:

When the move pointer becomes visible as a large X, press the

mouse button. The handles appear, indicating that you have selected the

drawing object and can now manipulate it. To deselect the drawing

object, click outside of it.

4. Now try to place the pointer exactly over the border of the drawing

object outside of the 8 handles. Click and drag it. You will notice that the

pointer turns into a hand. We will need to use this technique later.

5. You can move a selected drawing object by moving the move

pointer in the desired direction. The pointer again becomes a rectangle

with an arrow attached to it. A �ghost� object moves with the pointer for

your orientation. When you release the mouse button, the object

reappears.

Han

Move or select pointer

< 
pra



Creating a One-Page Document 31  �  Notes



Duplicating and Deleting Drawing Objects32
Duplicating and Deleting Drawing Objects
6. You often need several identical drawing objects, as you will in a

later exercise. It would not be very efficient to draw each object

separately; instead, you can duplicate an existing object. RagTime offers

several ways to do this:

> Select an object. Then choose the Duplicate command from the

Edit menu. A duplicate of the drawing object will appear on top of the

selected rectangle. Move the duplicate to the desired position on the

page.

> Select an object and keep the mouse button pressed. Press and

hold down the Ctrl key. Move the ghost object to the desired position.

When you release the mouse button, the duplicate becomes visible.

7. If the results are not as you had hoped, you can easily delete

particular or all drawing objects. To do so, select the appropriate object

and press the Delete key.

Enlarging and Reducing Drawing Objects
A drawing object you create rarely has exactly the size you need. But

changing its size is no problem. To modify the dimensions of an object,

proceed as follows:

8. Select the object. The handles appear.

9. Position the pointer exactly over the middle handle on the side that

you want to adjust, for example to drag out and enlarge the object. The
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B / A You can restrict the direction that you drag objects to vertical

or horizontal by pressing the Shift key (s). This is handy because you

don�t have to control the mouse so precisely.

A To align several identical objects evenly, you can set the distance

interval among the newly created objects under Duplication Offset in

the Extras>Settings>Drawing panel 

A When you duplicate an object, move it, and immediately duplicate

again, RagTime 5 notes the distance that you moved the first duplicate

and applies it to subsequent duplications. Try it out and you will notice

that this method works only if you don�t select another object between

duplications.

B You can use keyboard shortcuts for many commands in RagTime 5.

Shortcuts appear in the menus next to the commands. You can also use a

shortcut to duplicate an object:

Select an object. Press the key combination Ctrl+D (press �D� while

holding down the Ctrl key). Move the duplicate that appears to the

desired position

B Many users have a personal preference when it comes to working

exclusively with the mouse or using keyboard shortcuts once in a while.

Since certain keyboard shortcuts are used by many other programs, you

will probably memorize Ctrl+S (Save Document) in no time and use it to

save documents �on the fly.�
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pointer changes to a crosshair.

10. Drag the handle outwards. The drawing object is enlarged. (See the

illustration.)

In an analogous manner, you can enlarge the object to the left, top

or bottom. Likewise, you can reduce the object by moving a side inward.

The four corner handles act in a similar manner. Whereas dragging a

middle handle lengthens or shortens opposing sides, dragging a corner

handle lengthens or shortens the adjacent sides.

The three phases in this case, again an enlargement, appear as fol-

low:

This concludes the brief introduction to drawing objects. We will

return to this subject later.

Now is a good opportunity to take a break. Next, we will take a look

at the contents that can be inserted into a drawing object.

Direction of motionCrosshair pointer

Crosshair pointer Direction of motion
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A The round handle at the center of a drawing object can be used to

rotate it. Wait until chapter 5.3 for an explanation or experiment on your

own now: click on the handle, slightly move the pointer away from the

object, and move the mouse up and down slowly. The ghost frame will

help you keep track of where you�re going.

B / A RagTime maintains the proportions of a drawing object when

you drag a corner handle while holding down the Shift key (s).
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Using Drawing Objects as Containers
So far you have only used the drawing tools to create drawing

objects. The next step is to determine what contents should go in the

objects. First delete all the objects that you have drawn on the page.

(Select them and press the Delete key.) The page should be empty, but

the printable area remains visible.

11. Draw rectangles: draw

the three rectangles A, B, and

C as in the illustration.

12. Install text: click in rectangle A so

that the handles appear and choose the

command Drawing>Contents Type>

Text.

Your action had no apparent affect, but this impression changes

when you move the pointer over rectangle A without pressing the mouse

button.

The arrow pointer changes to a text pointer(✄✣ ), indicating that text

can be entered in the object under the pointer.

13. Enter text: click again while the text

pointer is over rectangle A. The rectangle is

now prepared for text input. Notice that the

pointer has changed again. The text pointer

has become an insertion marker (|) that you

may be familiar with from other word processors. Now type a sentence,

e.g., �This rectangle contains text.�
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B / A As you have no doubt noticed, after you have drawn an

object with the rectangle tool, the selection pointer is automatically

active again. This is usually handy, but a nuisance when you want to

make several objects with the same tool.

To draw a number of objects with the same tool, press Ctrl while

clicking to determine the first point of the new object. The tool used last

is then used again without your first having to select the tool in the tool

bar.
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The result should look something like this:

Having done this, you will have no trouble filling

rectangles B and C with other contents.

14. Installing a picture: Drag open a roughly

identical rectangle beside rectangle A using the

Rectangle tool. Then select Picture from the

Content Type tool. The drawing object contains an

initially empty picture.

Here�s the result:

To learn how to insert a picture in the rectangle turn to the

explanation in section 4.2. Please be patient. The focus here is preparing

drawing objects to accomodate contents.

But please keep an eye on the pointer when you move it over a

drawing object.

15. Installing a spreadsheet: Use the Rectangle tool once again to drag

open a frame. This time, however, hold the mouse button down a bit

longer while the pointer is over this tool. This will

pop open a menu with which you can directly

determine the content type before the drawing

object is even created. Select the Spreadsheet

content type and draw rectangle C. The drawing

object now  contains a spreadsheet.

Here�s the result, once again:

The illustration shows the typical structural elements of a

spreadsheet, rows and columns, as well as the characteristic

spreadsheet pointer. You will learn more about spreadsheets in section

4.3.

At this point, we must draw your attention to something important!

> Click outside all the objects or on the toolbox located in the tool

bar. 
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B / A Because installing text in a container is a very common pro-

cedure, RagTime 5 offers a shortcut: if an empty object is selected (the

handles are visible), you can simply start typing. The Content Type of

the object is automatically set to Text, the installed text component is

active, and you can enter and edit the text.
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This makes the drawing tools reappear. You can select any tool and

begin drawing. 

> Click the text in rectangle A and look at the tool bar. It appears as

follows:

A lot has changed. We will look into this in detail later.

> Now click the picture in rectangle B. Picture tools appear in the tool

bar.

> Finally, click the spreadsheet in rectangle C. The spreadsheet tools

appear.

The important point is that any time you click in an object with

contents, the tool bar changes according to the situation. RagTime

makes sure that the tool bar always provides tools which are appropriate

to the environment.

Take another look at the Content Type menu. In addition to Text,

Spreadsheet and Picture, you will see a number of other choices.

> Context sensitive
tool bar



Creating a One-Page Document 41  �  Notes
B Additional information on all tools can be found in the Reference

Manual and the on-screen help.
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> Content Type: No Contents

If you want to use drawing objects only as elements of illustrations

without assigning them any special contents, leave the setting No

Contents. The advantage is reduced storage and memory requirements.

RagTime needs only to save geometrical shapes, which makes the

document significantly smaller.

> Content Type: Drawing

If you assign the contents type Drawing to a drawing object to, you

can make a drawing inside the container. This has all the advantages

inherent to containers. You example, you can copy the drawing by

copying the container. You can move the drawing by moving the

container. You can distort the drawing by distorting the container, and so

on.

> Content Type: Text, Spreadsheet, and Picture

These contents types were discussed above.

> Content Type: Graph:

�Graph� is a collective name for the many possibilities RagTime

offers to represent values in informative graphic displays. You can often

present values more meaningfully in column, bar, line, point, or multiple

value axes diagrams, to name just a few.

> Content Type: Button

A Button is yet another content type. You can use it to perform

tasks such as printing, sorting, etc. within your document. You can make

your buttons non-printable so they don�t interfere with your print-out.

Unfortunately, we�ve run out of space, so we can�t give you further

details on this feature. Please refer to our on-screen documentation

under Info>Reference for more information. 

> Content Type: Sound

Last, but not least: Sound. You can use this content type to add

audio capabilities to your document. Once again, space limitations

prohibit us from elaborating on this type of content. Please refer to our

on-screen documentation under Info>Reference for more information.

This is another good opportunity to take a break!
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The objects which you have drawn so far are all on a page of a

layout. You can, however, install a drawing component in a drawing

object by choosing Contents Type>Drawing. The differences between

the ways of drawing and how to take advantage of them are explained in

exercise 4.
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4.2 Exercise 1: Business Letters Made Easy

the form of a business letter (see the illustration) using basic

techniques. Every step in this example is described detail. The

commands and techniques shown here will be used in later exercises

without further comment, in order to concentrate on the new material.

The illustration depicts a RagTime page which contains various

drawing objects having different contents, called �components.� Please

examine the illustration carefully so that the objective will be clear to

you. 

The letter consists of five texts and one picture. The container

borders do not appear in print. You can also make them invisible on the

screen if you want to see how the finished letter looks in print. Use the

command Windows>Show>Nonprinting Items. The command

switches between on (+) and off (no +). Try it out.

Once you are familiar with the goal of the exercise, you can create

and position the objects, and then fill them with contents.

That means

1. Structure the layout of the letter on a page having standard letter size.

2. Write the texts in the intended places and format them.

Beginning a New Document
Choose Start>Programs>RagTime>RagTime or your preferred

method to start the program. If RagTime is still running from the last

exercise, choose the command New Document from the File menu. A

window containing a layout and standard rectangle appears, and the tool

bar contains layout tools.

Goals
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text
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picture, text,

Body
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Footer

text

Address field

text
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Determining the Page Setup
Make sure that the correct paper format, in this case, US Letter,

portrait, is selected under the command Page Setup in the File menu.

The Containers for the Letterhead
1. First of all, we want to roughly adjust the standard rectangle that

appears with every new layout so it is ready to accomodate the body

text. This should also free up the space needed for letter components at

the top of the page. To make work easier, set the display scale to 50%

under Windows>Display Scale>50% for the time being. 

2. Now reduce the standard rectangle so that it occupies the bottom

half of the page as in our example. To do so, place the pointer on the top

center handle. It will turn into a  cross, indicating that you can reduce the

frame�s size by dragging downward. Once the rectangle has been

adjusted to the desired height, restore the original, 100% scaling by

selecting   Windows>Display Scale>100%. If necessary, move the

rectangle up a little to free up space to insert company information in the

footer.

3. Click on the Rectangle tool on the tool bar and create the two

rectangles for the company name and logo as shown in the illustration.

4. Assign the content type Picture to the left rectangle and Text to the

right one. (Remember how to do this? Select a rectangle and assign the

desired attributes under Drawing>Content Type>(Your choice) from

the menu bar or the Content Type tool.) Check to make sure your results

match our example.
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The contents of the dialog box depend on the printer being used, so

they may vary from the illustration. In case of doubt, please refer to your

printer�s documentation.
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Creating and Positioning the Date Field
5. Click on the Rectangle tool in the tool bar and hold down the

mouse button for a while unntil a pop-up menu appears. Select the

content type Text.

6. Draw a rectangle where the date is to appear, below the letterhead,

with the left side of the rectangle approximately in the middle of the

page. Make sure the rectangel remains selected.

Creating and Positioning the Address Field
7. Click on the Rectangle tool in the tool bar and hold down the

mouse button for a while unntil a pop-up menu appears. Select the

content type Text.

8. Draw a rectangle in the approximate position of the recipient�s

address. Make sure the rectangel remains selected.

9. Call up the information dialog for this drawing

object by selecting Drawing>Get Info from the

menu bar. This will reveal the Drawing

Information panel.

10. Choose the Coordinates panel.
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The Information Dialog
You can also open the Drawing Information dialog box with the

appropriate button in the tool bar

Double-clicking most drawing objects also opens the Drawing

Information dialog box. Exceptions are the drawing objects which can

be edited in parts, that is, those which permit subselections. This group

includes polygons, Bézier curves, and graphic texts. Double-clicking

these objects activates the editing mode. You can change this behavior

in the Drawing panel of the dialog box opened by Extras>Settings.

If a component (a text, a picture, and so on) is already installed in a

drawing object, please double-click the border.

If you�re not certain of the effect your entry will have, select Apply

first. RagTime will take your entries into consideration. However, if your

entries do not generate the result you intended, you can reinstate the

original value or enter new ones. The Apply command can also be used

to make changes in several of the information dialog�s panels without

having to call up the dialog repeatedly.

A Contextual Menus
The program features so-called contextual menus depending on the

objects you are working on within RagTime. They pop up when you press

your right mouse button anywhere within your current working environ-

ment.

RagTime recognizes the context in which you have clicked and

reveals the corresponding menu. They (almost) always contain two

elements:

> Contextual menus let you access the selected object�s information

dialog.

> Contextual menus contain the following commands, which can also

be found in the Edit menu: Cut, Copy, and Paste. Exceptions are made

when such commands are useless in the active work environment.

Contextual menus aim to make frequently used functions available

�on the fly,� eliminating the need for time-consuming mouse operations.

Try this out and make a mental note of the contextual menus that make

your work easier. Contextual menus are also used in the Windows opera-

ting system and other programs.
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Assuming that you want to send your business letter in a window

envelope, enter the settings in the panel as shown in the illustration. The

rectangle jumps to the correct place and has the correct dimensions. Fast

and easy, wasn�t it?

The Body of the Letter
11. Adjust the height of the body of the letter, if necessary.

12. Use the Drawing Information dialog box, if needed, to position the

rectangle 1 inch from the left edge of the page.

The Footer with Contact Information
13. Select the rectangle tool from the tool bar and set the content type

to TEXT in the tool bar.

14. Draw a rectangle of the desired size for the letter�s footer.

15. Use the Drawing Information dialog box, if needed, to position the

rectangle 1 inch from the left edge of the page.

Now that you have laid out the page with drawing objects and

installed components in them, you can begin filling the components.

Start with the easiest: insert a picture.

Where Can You Get the Company Logo?
Of course, the letter doesn�t have to have a logo when time is short.

But, as you will see, you can get one fast if a finished picture is available.

> You might have one done by a graphic artist and supplied on a disk,

or

> You may have designed one yourself using a special program, or

> You may have ordered finished pictures from your dealer and

modified them.

If you don�t have a logo handy, you can use one supplied with

RagTime. Our picture files are located in the �RagTime\Examples\

Training� folder on your hard drive. Irrespective of whether you intend to

use one of your own or RagTime�s pictures, you need to launch the

program required to process the file, i.e., the Windows Explorer.
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A To help position objects, RagTime 5 provides a grid which you can

turn on with the command Window>Rulers and Grid>Snap to Grid.

For more information about creating and modifying grids, please refer to

the on-screen documentation under Info>Reference.

If you want to position a number of objects

precisely instead of opening the Drawing

Information dialog box, it is better to open a

palette with the command Windows>Palettes>

Object Coordinates. The palette can remain open

on the screen and always shows the values of the

selected objects. This way you can save repeatedly

opening and closing the Drawing Information

dialog box.

To edit a value in the palette, click in the

appropriate field. Complete an entry by pressing

Enter.

A You can place palettes anywhere you want on your screen. We�ll

come back to this later.
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Creating a Company Logo from a Picture File
16. Choose Start>Programs>Windows Explorer. This will open

the Explorer with the settings you used last. We will use the Explorer to

import the picture of your choice into your RagTime document.  To do so,

drag and drop the icon of your picture of choice from its location in the

folder hierarchy to the desired picture container.

17.  Before performing

this operation, make sure

both the Explorer and the

RagTime windows are

visible on your monitor

side by side. If necessary,

click Restore in the title

bars to deactivate the

respective program�s

Maximize mode. Then

resize the programs�

windows so they each take

up approximately half the

available monitor space.

18. Within the Explorer,

select the folder which

houses your picture or go to the �RagTime\Examples\Training� folder.

Click on the picture of your choice or the file named �Electric Bulb� in the

�Training� folder and drag the file icon out of the Explorer window and

into the RagTime window and drop it into the rectangle set to

accomodate the picture in the top right-hand corner.

19. The picture appears in the rectangle, retaining its original

proportions.

20. Click on the picture to select it. To make

the picture fill the container, choose Picture

>Fit Container to Picture from the menu

bar. Your company logo is ready

Formatting the Text of the Letterhead
In this step, we will work on the text of the letterhead.

21. Click in the rectangle for the text. The insertion marker blinks in the

upper left corner.
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B / A You can also import picture files into a selected picture

container via the File>Import menu.

To transfer a picture, or anything else, from a folder to a RagTime 5

document, you can drag the object from its source folder in the Explorer

to the appropriate place in your document.
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22.  Type �Bright Ideas, Inc.� and

press the Return key (r). Type

�Interior Illumination.�

23. Select the text by dragging across

it with the text pointer from beginning

to end.

24. Choose, for example, Arial from

Format>Font in the menu bar.

RagTime will initially show a subset of

the available fonts. To display

additional fonts, click on More. 

25. Choose, for example, 24 pt

from Format>Size in the menu

bar.

26. Repeat the process  for

�Interior Illumination,� using a

different font size and font, if

necessary.

27. To center the text of the

letterhead, select the entire text

and choose Format>

Alignment>Center.

Completing the Date Field
28. Click in the date field.

29. Type the date as it appears in the example.

Completing the Address Field 
30. Click in the address field.

31. Press Return (r) several times until the text pointer is at the height

of the first line of  text.

32. Type the address as it appears in the example.
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You can prevent objects from accidentally being moved with the

mouse. This is particularly handy, for example, when you work with your

notebook in a moving vehicle.

Select the objects and choose the command Extras>Pro-

tection>Fixed.

You can still change the coordinates by entering new values in the

Drawing Information dialog box or the Object Coordinates palette.

Only attempts to make changes with the mouse are rejected with an

error message.

Fixed objects are identified on the screen

with a pin through the arrow pointer

The font belongs to the character format, which you may set

differently for each character. If you want to affect several characters,

you must select them before changing the font. Character formats

comprise the top section of the Format menu.

A If you want frequent access to different fonts and you haven�t

created any suitable paragraph style sheets, you can tear off the

Format>Fonts menu and place it on screen like a palette. To do so,

hold the mouse button down for a while on a Format>Fonts menu

entry and slowly move the pointer sideways. A ghost frame will indicate

the location of the Fonts menu palette
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33. Below the ruler, a gray bar having the width of the text container is

visible. In the bar, you will see left and right margin markers.

To make the address better visible in the envelope�s window, you

can move the text a bit to the right.

34. Click in the address field and choose Edit>Select All from the

menu bar. This insures that all paragraphs are included in the ensuing

realignment.

35. Now move the arrow pointer precisely over the bottom left margin

marker and drag it to the right holding down the mouse button. Ghost

lines help you align the text.

36. Release the mouse button, click once to end the text selection, and

look at the results.

Text for the Footer
The text data are entered in much the same way as in the address

field. However, here a number of small blocks of text need to be entered.

To position these blocks, you need to use tabulators, predefined

positions to which the insertion marker jumps when you press the

tabulator key ( t). Tabulators are particularly useful when words in

several lines must be aligned in columns.

Ghost line
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Alignment is part of a paragraph format. The selection must be in

the paragraph of which you want to change the setting. If a number of

paragraphs are to be formatted together, take care that you select them

all by dragging across them with the pointer.

Paragraph formats always affect the entire paragraph; that is, all the

lines of a paragraph must be, for example, aligned right. If you want to

affect individual lines, you must divide your text into appropriate para-

graphs.

The left margin marker has two parts. The upper half marks the left

margin of the first line of a paragraph. The lower half marks the left

margin or the remaining lines of a paragraph. When you move the lower

part, the upper part moves as well. You can move the upper part

independently. If you want to move the lower part independently, hold

down the Alt key.

To set new tabulators, first select a type of tabulator, such as left

aligned, centered, or right aligned, in the tool bar. Then click in the gray

bar. Experiment with the tabulators.

Margins belong to paragraphs. Therefore, the selection must be in

the paragraph of which you want to set the margins.  If a number of

paragraphs are to be formatted together, take care that you select them

all by dragging across them with the pointer.

If the margins of all paragraphs of a text are to be adjusted, of

course it is easier to use the command Select All than to select them

with the pointer.
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aution: Never use
ks to align text!
Never use blank spaces to align words, even though using tabu-

lators may seem strange at first. Otherwise your printed document will

be unusable, and revisions are difficult. Incidentally, this is true not just

for RagTime but for all word processing done with computers.

Aligning the Text of the Footer with Tabulators
37. Click in the footer rectangle.

38. The text tools appear in the tool bar, and under the ruler the margin

and tab markers are visible. You can arbitrarily position different tab

markers, but for this exercise the automatic tabs are sufficient.

39. Choose Format>Size>9 pt. First type �Phone� and press ttt;

type �Fax� and press ttt; type �E-mail� and press r.

40. If you have inadvertently pressed the tabulator key once too often,

correct the error with the Delete key.

41. Type the telephone and fax numbers and e-mail address, using

tabulators to align them with the corresponding titles.

The Body Text
Now that you have done the preceding exercises, you can try out

your knowledge on the last text.

42. Use the example letter for the body of your letter. Indent the product

descriptions by pressing the tabulator key. Do the same with the prices.

43. You can use the Format menu

to emphasize text, in this case the

bold typeface used for the product

names (Format>Style>Bold).

The Format menu lets you

determine even more styles using

options that are more deeply nested

such as the Format>Style>

Kerning and Positioning menu.

Feel free to experiment!

< C
blan

Margin marker Margin markerAutomatic tabulators
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B / A If you want to replace a word with another in a large docu-

ment, you can save time by using the Edit>Search

and Replace dialog. To enter the term you would like

to replace the search term with, click on the bottom left

triangle and fill in the required fields.

Please note that you can use the Specify button to

determine the format of the searchable term and set

the range of your query in the IN field.

Arranging elements in the footer is easy with the tabulators. For more

complex tables with lines or a number of columns, using a spreadsheet is

usually advantageous because the column width and other settings are

easier to change. The spreadsheet is an excellent tool for structuring

tables even when you don�t need to calculate anything. You will find

examples in the following exercises.

Inventory
You have designed your business letter by drawing rectangles in a

layout and installing various contents (texts and a picture) in them.

These contents are called components in RagTime 5. They are displayed

in drawing objects.

RagTime organizes all the components for you in the inventory.

Open it with the command Windows>Palettes>Inventory or click

Roderick the Squirrel in the tool bar. The inventory gives you an overview

of the elements in the active document, i.e., auxiliaries such as style

sheets or rulers and their components like texts or pictures.

You can flip inventory parts open or shut as you would in the

Windows OS to reveal the part you�re interested in. If you need

additional space to view the inventory on your screen, enlarge the

Inventory window by moving the window separator to the left. To hide

the inventory, simply give Roderick another click!

The names of the components are assigned by RagTime. You can

select and edit names just as you do with file names in the Windows

Explorer.

If you double-click the name of a component in the inventory, a

window opens in which just that component appears, independent of its

position in the layout.

You can acheive the same result in layout mode by selecting a

component and then clicking on the Open Component tool.
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Printing the Finished Letter
44. Choose File>Print from the menu bar.

45. A dialog box opens in which you can set various options for printing.

The content of the dialog box depends on the type of printer connected

to your PC, so it may vary from the illustration. If in doubt, please refer to

the documentation for your printer.

Don�t Forget to Save
You will find the save command in the menu

bar under File.

46. Choose File>Save As�.

47.  Enter the file name �Business Letter� in the

space provided.

Please refer to your Windows documentation for detailed

information about saving and naming documents. Windows allows you to

use spaces to make file names more legible, e.g. �Letter Re Court Case

Meyer vs. Meyer.� However, certain characters such as: �/�, �?�, �|�, etc.

cannot be used. More detailed information on this is included in your

Windows documentation.
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A When managing large documents, since the inventory�s components

are arranged alphabetically, we recommend giving related components

names that appear in sequence to gain a better overview. You can

achieve this by assigning the same prefix to all the components be-

longing to the same layout, e.g. �Chap1 Layout,� Chap1 Pic1,� etc.

B If you have already printed a document during the active RagTime

session and you would like to print the current document using the pre-

selected printer without going through any further dialogs, simply

choose File>Print One or click this button.

B If you would like to share documents with colleagues using RagTime

5.0.1, simply save your document as a RagTime 5.0.1 file using the File>

Save As dialog and choosing RagTime 5 document from the Save As

Type pull-down menu.

The button File Compacting When Closing determines whether or

not gaps created through deletion of document parts will be removed

when the file is saved. This way documents which are regularly changed

can be stored using less storage capacity.

Please note, however, that features such as title rows in spread-

sheets and color style sheets that are only available in RagTime 5.5

cannot be used when working in RagTime 5.0.1 documents. A warning to

this effect will pop up on your screen before you finish saving your work

as a RagTime 5.0.1 document.
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4.3 Exercise 2: RagTime Does Your Calculations

In this exercise, you will learn some basic techniques for working

with RagTime spreadsheets. The result of the exercise should look like

this:

You will learn about the characteristics and structure of a spread-

sheet.

You will enter numbers and texts, construct simple formulas, and

learn ways to design a spreadsheet to fit your needs.

The illustration above shows an example with which you can

become familiar with spreadsheets step by step using basic calculation

features. In the course of time, you will discover just how powerful this

tool is. You will learn ways to simplify entering identical or similarly

structured data in more than one cell. 

The table consists of six columns with the titles �Value 1� to

�Results.� It includes seven rows with the titles �Addition� to �Column

Totals.�

The upper left and lower right cells remain empty.

The shaded area contains the values which are added for each

column in the row �Column Totals� (25+25+25+25+25, and so on).

In the column �Results� you see the solutions for calculations

performed with rows (adding the values 25 + 100 + 50 + 200,

subtracting the values 25 - 100 - 50 -(-200), and so on).

Beginning a New Document
Choose Start>programs>RagTime>RagTime or start the

program using your preferred method. If you left RagTime running since

the last exercise, choose New Beginning With from the File menu and

begin with a new layout. A window containing a layout opens, and the

tool bar contains layout tools. Delete the active standard rectangle

displayed when RagTime starts using the Delete key. (It has a

mechanism for creating new pages which would get in our way during

this task.)

Make sure the correct page size, US Letter, appears in the Page

Setup dialog box in the File menu.

Goals
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A If you don�t like the position of the tool bar at the top of the window,

you can move it elsewhere. Grab the double bar to the left of the tool bar

and drag it to the desired position. The tool bar becomes a palette which

you can put anywhere. Also, you can change its size using Windows

procedures.

To �dock� the palette under the menu bar, drag it back onto the

menu bar. You can dock it on any of the other borders of the RagTime

window as well�left, right or at the bottom. Click on Close to make the

palette disappear.

A When RagTime recognizes a logical relationship between two con-

tiguous selected spreadsheet cells, it completes the sequence by filling

in the cells selected by dragging the handle. Let�s try it out. Enter the

values 2, 4 and 8 into three neighboring cells. Select the three cells and

drag the last cell�s handle over the cells you want RagTime to fill in for

you. The cells are automatically filled with the values 16, 32, etc. Voilà!

Choosing Spreadsheet>Fill Row... reveals additional ways to mani-

pulate cell contents to fill in entire rows.

A RagTime displays a default standard rectangle that automatically

appends new pages when text �spills over� the rectangle. However, you

can switch this function off in the Extras>Settings>Layout panel.

Simply uncheck the box �Begin with a Rectangle with Text and Pipeline.�
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Spreadsheet

menu

Spreadsheet tool

bar with entry field

Column titles

Cell with the 
address E11

ns

Row 1
Creating a Spreadsheet
1. Create a spreadsheet by drawing an object and choosing Drawing>

Content Type>Spreadsheet from the menu bar.

2. Click in the spreadsheet. The layout window and the tool bar now

look like this:

Spreadsheet Nomenclature
Before we begin, we should clarify some terms, which you can

compare with the spreadsheet illustrated above:

> A table consists of vertical columns and horizontal rows.
> Columns are labeled with letters (A, B, C - Z, AA, AB, �),

and rows are labeled with numbers (1 - 16,000).

> The intersection of a row and a column is a cell.
> Each cell is accessible with a unique address (for example, C6).

A Friendly Reminder: Please Save Now
In the last exercise, you didn�t save the result of your work until you

were done. From now on, you should do things differently. Why? If you

need to ask this question, everything has gone smoothly so far. No

co-worker or family member wanted to change a fuse at an inopportune

moment or caused a short. None of your children played with the cord.

Nor did your PC experience one of its rare crashes.

But you know what we�re talking about, right? Losing hours and

hours of work on your computer. So, although it�s still empty, please

save the document with the File>Save As� command under the name

Selected cell with the address C4 with handles for fill-iColumn ARow titles
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The expressions spreadsheet and table are used synonomously

here.

If you click in a cell of a spreadsheet, it becomes the selected cell. If

you drag with the pointer across a number of cells, all of them are

selected.

Selected cells are marked with inverted colors on the screen (white

becomes black, and so on). Format commands, for example, Font, al-

ways affect all selected cells. Similarly to selected objects, every selected

cell has four handles. They can be used to copy identical contents to,  or

complete data sequences in, neighboring cells at the click of a mouse.

We�ll go into more detail about this later.

If you now begin to type, naturally the entry can only go into one

cell. This cell is the active cell.

The active cell is marked on the screen with a moving broken line

called the ants. All entries of cell contents are always put into the active

cell.
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Save regularly
�Exercise 2� on your hard disk before continuing. Continue to save in

regular intervals by choosing File>Save Document from the menu bar,

or using the Ctrl+S keyboard shortcut.

One thing we don�t want is for you to have trouble working with

RagTime.

Navigating in the Spreadsheet
3. Click in cell A1. The cell is selected. Click in another cell. The

selection of cell A1 is canceled, and the new cell is selected.

If you don�t want to take your hands from the keyboard in some

situations, and if a cell is selected, you can select its neighboring cells

with the arrow keys.

4. With r, you can select the cell immediately below. If you press the

Shift key (s) simultaneously, the cell immediately above is selected. 

5. Press t to select the cell to the right. If you press s, the direction is

reversed here as well.

Entering Text in the Spreadsheet
6. Click in cell B1 to enter the headings in the rows B through F.

7. Type �Value 2�, and so on, to �Result.� Press t after each entry to

select the next cell.
8. Click in cell A2 to enter the labels in rows 2 through 7. Press r after

each entry. 

9. Continue in the same way to enter the values.

10. The results should look like this:

When you study the table, three things stand out:
> In the first column (column A), the word �Multiplication� is cut off,

and �Column Totals� protrudes into the next column (column B).

< 
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The effect of the keys for navigating in spreadsheets (arrows, tab

and so on) depends on whether one or several cells (a range) are

selected. If a range is selected, navigation using t and r is limited to

the range. Using the arrow keys, however, takes you out of the range and

cancels it.

While editing the contents of a cell, for example, by entering text,

the arrow keys work only within the cell and can be used to move the

insertion marker. The  t and r keys and the mouse are available to

select other cells and end the editing in the active cell.

To complete an entry without selecting another cell, press the

Return key (r). To end the editing of a cell without keeping the

changes, use the Esc key.
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1oo
1OO

100

 100
> All the texts begin on the left sides of the cells (left aligned).

> All the values, in contrast, are to the right in the cells (right aligned).

The explanation is that RagTime normally aligns text left in cells and

values right. Of course you can change this, but it is the initial setting.

Value Types in Cells
Please refer to the illustration below. It contains the number 1,000

five times. For the reader, yes, but not for the computer!

To discover such errors, you can select the suspected cell and check

in the tool bar which value type the cell contains. The possibilities

include, among others, text, number, date, and time span.

Changing the Column Width and Cell Height
11. Select a cell in column A. Position the pointer exactly on the

separator line in the column title bar between columns A and B. The

pointer changes its appearance. Press the mouse button and hold it

down.

12. Notice that the pointer has changed and the line between columns A
and B is highlighted (ghost line).

1000
o
O

0 

0

> This 1000 is entered correctly.
> This 1000 was entered with the lower case letter �o.�
> This 1000 was entered with the upper case letter �O.�
> This 1000 was entered correctly, but contains a blank space at the

end, a particularly nasty mistake!
> This 1000 was also correctly entered but contains a blank space at

the beginning, which is noticeable. This error occurs especially with

novices from time to time.

Pointer on separator line
�Ghost� line
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B / A You can easily copy identical values from two or more cells

to several cells right in  the spreadsheet by using the fill-in function.

Here�s an example:
1. Create a new spreadsheet. Enter the value 25 in cell A1. Conclude

the entry with R.

2. The cell is now selected and has a �handle� on each side. Drag the

bottom handle over the four cells below.

3. RagTime copies the content of the orignally selected cell into the

four lower cells.

You can use this feature to copy any kind of cell content, including

formulas. We will familiarize you with additional and more complex

operations that enable you to work even faster using RagTime�s fill-in

features later on.

RagTime analyzes your entries in cells and assigns each a value type

according to the following rules:

> Numbers consist of digits (0-9), the positive and negative signs (+,-),

decimal points (.), thousands separators (,) and exponential notation

symbols (e or E).

> Dates (calendar dates and points in time) consist of numbers and

additional characters defined by the system software of your computer.

Please refer to the Date/Time control field under Start>Settings>

Control Panel. When you enter dates without a century indicator,

RagTime prefixes them with 20 for entries from 1 to 25 and with 19 for

entries higher than 25.

> Currency symbols with existing value formats.

> Time spans consist of numbers and the abbreviations d for days, h

for hours, m for minutes and s for seconds. At least two of the

abbreviations must appear in the entry. For example, if you want to enter

two hours, type �2h 0m� or �0d 2h�.

> Text is any entry for which none of the above rules do not apply.

A blank space at the end of a text is often hard to recognize. If you

suspect that such a character has caused a value to be misinterpreted,

you can make it, and other such characters, visible on the screen by

choosing Windows>Show>Special Characters. You can see them in

the entry field in the tool bar.



Calculating the Sums of the Columns70
13. Move the mouse to the right so that the ghost line is directly behind

the word �Totals.�

14. Release the mouse button. The column width changes as desired.

15. You can change row heights analogously.

Calculating the Sums of the Columns
Next you should find the sums of columns B through E. To do so,

you will enter formulas in B7, C7, D7, and E7 successively. The

formulas which we treat here all calculate the sum of their respective

columns; however, some differ significantly in appearance and the

manner in which they are entered.

This way you will learn various methods of entering formulas, all of

which you will later use more or less frequently.

Calculating the Sum of the First Column
16. Select cell B7.

17. Type an equals sign (=) or click the abacus in the tool bar.

The Formula palette appears. Move it so that the spreadsheet is

not covered.

Formula target (the cell or text in the cell)
Confirm formula entry

Cancel formula entry
Switch between absolute and relative addresses

Open function list
Formula entry field
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A If you select several columns, or cells in several columns, and then

drag one of the separator lines between the column headers, you can

change the width of all columns simultaneously.

> Example 1: Select the first 5 columns of a spreadsheet and click on

the separator between columns 3 and 4. Holding down the mouse

button, slowly move the separator to the left, and then to the right. The

selected columns to the left of the dragged separator become narrower

or wider, proportional to their original widths, while those to the right

analogously become wider or narrower, maintaining the initial total

width. 

> Example 2: Once again, select the first 5 columns of a spreadsheet

and click on the separator between columns 5 and 6. If you drag the

separator line at the far right of the selection, all the selected columns

will become proportionally wider or narrower, and the total width

changes.

> Example 3: Make column A substantially wider, about twice as wide

as column B. Once again, select the first 5 columns of the spreadsheet

and select the separator between columns 5 and 6. If you hold down the

Shift key (s) while dragging, the same change is applied to all selected

columns; the original width is ignored and the total width changes. Try it

out!
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18.  Click in the formula entry field of the Formula palette. (Click in the

field before entering each formula to initiate the entry. The buttons are

also available then.)

Formulas are created by joining cell addresses and constants with

operators, for example, plus (+) and minus (-).
19. Type the following formula in the entry field: �b2+b3+b4+b5+b6�.

(Lower case letters are permitted.) If you make a typing error, you can

correct it much as you do in word processing.

20. When you have completed the entry, press Enter or confirm the

entry by clicking the + in the Formula palette (in short, check it off). If

the entire formula is wrong, cancel the formula instead of confirming it.
21. The first formula is finished. The result appears in cell B7.

Typing the formula was admittedly tiresome, but now things will get

easier.

Calculating the Sum of the Second Column
22. Select cell C7 for entering the next formula.

23. Is the Formula palette still visible? If not, click the abacus. Then

initiate the formula entry by clicking in the entry field in the palette. The

mouse pointer becomes a spreadsheet pointer with function symbols

attached to it. This indicates that the desired formula will be applied to

the selected cells.
24. Click in cell C2 and then in cells C3, C4, C5, and C6 successively. 

25. If you check the Formula palette now, or if you watched while

clicking the cells, you will notice that RagTime entered both the cell

address and the plus sign. This works only with addition.

26. You need only to check off the formula, and the result will appear in

cell C7.

Inserting cell addresses by clicking is a technique which you should

use in the future. It is not only more convenient than typing, but

significantly less error prone. Nevertheless, you sometimes need to type

addresses when editing formulas.

Calculating the Sum of the Third Column
27. Select D7 for entering the formula for the sum of column D (Value 4).

28. Since sums are probably the most frequent calculations in spread-

sheets, RagTime provides you with a special function, Sum (List), for

this. List represents the numbers which are to be added.

29. Is the Formula palette still visible? If not, click the Abacus again.

30. Click in the entry field of the Formula palette and enter the following

function:
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B If the formula entry field is too small for you, use the standard

Windows procedure to enlarge it by grabbing the enlargement point with

the mouse pointer on the bottom right corner and dragging it open.

RagTime ignores upper- and lowercase orthography when you enter

cell addresses or functions. When displayed, your entry is changed.

This does not apply to text used in formulas. Text is entered

between single quotation marks ('text') and is not changed by RagTime.

> A range is a group of adjacent cells which are selected or used in

formulas together, for example, the cells from A1 to F2 (A1:F2 in

formula notation), or the entire column B (B:B in formula notation).

> A list consists of two or more individual values or cells which need

not, but may be, adjacent to each other. Ranges may be used as

elements in lists. The following formula is therefore valid: Sum
(A1:A5;B3:B5;C3)
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31. Click cell D2 and hold down the mouse button.

32. Move the pointer downwards, dragging it over cells D2 through D5.

RagTime marks the range (D2:D5 in formula notation) with a border.

The range is entered in the formula, which now looks like this:

33. Complete the Sum function with a closing parenthesis.

34. Finally, press Enter again (or click +). The result appears in cell D7.

Calculating the Sum of the Last Column
35. You know the ritual by now. Select cell E7.

36.  Since not only sums, but virtually every mathematical calculation

imaginable must be calculated in spreadsheets, RagTime masters an

abundance of functions from various disciplines.

Fortunately, you don�t need to remember all these functions, but

can get them from a list and have RagTime insert them in your formulas.

Click the Functions button in the tool bar or Formula palette.

37. The Functions dialog box displays an alphabetical list of functions
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B Another way of rapidly building the sum of a column or row of values

is by using the Enter Sum Formula tool. Click in the cell below or beside

the number sequence to be totaled and then click on the Enter Sum

Formula icon in the tool bar. RagTime enters the sum of the number

sequence in the cell you selected.

This method should be used only if the relation to the cells that are

to be summed up is unequivocal. However, if the result is not what you

expected, you can always check which cells are included in the sum in

the Formula palette
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which RagTime offers. Under Description, you will find information

about the purpose of the function and its arguments. All functions in

RagTIme have the same structure:

Function Name (Arguments). Arguments are values which the

function requires for execution.
The function Sum, which you have already seen, is likewise built

according to this structure:
> Sum(List)
> Function Name: Sum
> Arguments: (list of values)< enclosed in parentheses.

Additional arguments, if present, are separated with semicolons, as in

the illustration.

38. Click the �down� scroll arrow until the function Sum appears.

39. Select the function Sum by clicking the name in the list.
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Functions may be displayed not only alphabetically, but also

according to other criteria which you can choose in a pop-up menu.

You can open or close an individual category by clicking the plus or

minus sign preceding its title.

If this doesn�t display the functions� names completely, zoom the

window.

If you know the name of the function that you want to see in the list,

you don�t have to use the scroll bar. Just type the first few letters of the

name, and the list scrolls to the correct position.
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40. Click Insert.
41. The Formula palette appears with the function Sum. The blinking

insertion marker between the parentheses indicates that you can enter

the arguments.

42. Click cell E2 and hold down the mouse button.

43. Move the pointer downwards, dragging over cells E2 through E5.

RagTime marks the range (E2:E5 in formula notation) with a border.

44. Press Enter or check off the formula.
45. The result of the calculation appears in cell E7.

Calculating the Sums of the Rows
Now that you have worked intensively with the function Sum, it

won�t be any problem to add the numbers in row 2.

When you are finished with that, we can continue with the other

lines. Let�s begin with row 3.

46. To perform subtraction, you have to use the method �click a cell,

type the operator (minus sign), click the next cell, and so on.�
47. You will get the desired result in rows 4 and 5 with the same

procedure.

The operator for multiplication differs from that which you use on

paper.

Multiplication: not a dot or an �x� but an asterisk (∗)

For division:  always use the slash (/).
Lastly, the exponential calculation in row 6 must be explained.

Instead of the common notation for base and exponent, 252, you must

enter the following notation in the formula in cell F6: B6**C6 or B6^C6. 
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B / A Please note that, to type the operator ^, you must press the

^ key (usually located at top left on your keyboard) followed by a space.

The reason for this is that this symbol is normally used to create special

characters in the French character set where it�s applied on top of the

letter typed after it (it wasn�t originally intended to be used alone).
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Formatting the Table
To complete exercise 2, you still need to give the table a more

appealing appearance. This process, called �formatting,� covers an

abundance of features, the most important of which you will find under

Format in the menu bar.

To what degree you employ these features is a matter of personal

taste and depends on how polished your results should be, for there is

always something to improve or polish. Three examples appear below;

you will find more in later exercises.

First, align the headings in row 1 to the right, so the texts and

numbers are balanced. Then set the typeface of the headings and results

to bold. Finally, some of the cells should be shaded with gray fill.

48. Click cell B1 (Value 1) and drag the pointer horizontally to cell F1.

The five cells containing the headings are now selected.

49. Choose Format>alignment>Right Aligned from the menu bar.

The cell contents, the headings, move to the right. 

50. To set the headings and results in bold typeface, select the

appropriate cells and choose Format>Style>Bold from the menu

bar.

51. Finally, to make the table look like the example at the beginning of

the exercise, shade the values in the table in cells B2 through E6. Select

the range B2:E6 and choose the

command Format>Color>

(Gray) from the menu bar. 
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Many of RagTime�s submenus may be torn off and placed on the

screen as palettes. This is particularly useful when you want to use cer-

tain commands repeatedly or to check the settings, such as font, of

various selections without having to open a menu and look for a check-

mark each time. To tear off a menu, just drag out of the menu until a

ghost rectangle representing the palette appears.

Here�s what a torn-off color menu palette looks like.

The palette lets you switch back and forth between

Named Colors and RGB Standard Colors by clicking

on the tab of the corresponding panel. Among others,

Named Colors include the primary colors cyan, magen-

ta, yellow and black (CMYK) that constitute the

standard in the printing industry as well as additional

colors you may have previously defined under  Win-

dows>Auxiliaries>Colors. To assign a Named

Color to a selected object, simply select an entry from

this menu.

RGB Standard Colors is a palette of commonly used colors that

usually suits most purposes. Colors are selected by clicking a color on

the palette, which is then highlighted by a black

frame. At the same time, the color is displayed in the

box in the top left-hand corner. Double-clicking this

box displays the operating system�s Color Picker,

which you can use to mix additional colors. To assign

a color to an object, simply drag and drop the desired

color from the color palette onto the object. 

Regardless of whether Named Colors or RGB Standard Colors are

being displayed, you can use any of the three additional menus to give

the selected object additional properties. 

Left menu: This lets you determine which color is displayed and set, e.g.

a drawing's fill or border line.

Middle menu: Lets you define foreground and background colors or

patterns for two-color objects.

Right menu: Allows you to set a color's tint. Once you have decided on a

color, you can use this menu to lessen the color's percentual degree

of intensity.
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4.4 Exercise 3: Success in the Sales Department
Exercise 3 is a practical example in which you will learn further

spreadsheet techniques.

You will:

> learn more functions,

> save time by copying formulas,

> further your knowledge of formatting,

> insert and delete rows of a spreadsheet,

> change numerical data and discover the effects,

> present the numerical data more effectively in a graph.

The results should look like the following example. It contains the

monthly sales figures of three employees and a brief analysis.

Beginning a New Document
Choose Start>Programs>RagTime>RagTime or your favorite

method to start the program. If you left RagTime running since the last

exercise, choose the command New Beginning With� from the File

menu and begin with a layout. A window containing a layout appears

and the tool bar displays layout tools. Delete the default active standard

rectangle using the Delete (Backspace) key. (It has a mechanism for

creating new pages which would get in our way during this task.)

Creating a Spreadsheet
1. Draw a rectangle approximately the size of the one in the example

and give it the contents type Spreadsheet. 

2. Click in the spreadsheet. The spreadsheet tools appear in the tool

bar, and the row and column titles appear along the rulers.

Goals
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Entering the Values
3. Click in cell A1.

4. Enter into the table the values which appear in the illustration

below. Names of months in column A can be entered using the fill

function as shown below.

5. Enter "January" and "February" in cells A5 and A6, respectively.

Select the two cells and drag the lower handle to cell A16. RagTime

understands that it is dealing with month-by-month date-related in-

formation and completes the sequence by filling in the selected cells with

the remaining months. You may need to widen the cells to accomodate

words that run over the borders.

6. Save the document now under the name �Exercise 3� on you hard

disk.
< P
regu
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If a spreadsheet cell contains text which is too long to be displayed

in the cell, the display (but not the actual text) is clipped at the cell bor-

der. However, if the neighboring cell is empty, its space is also used to

display the clipped text.  This also applies to cells with rotated contents.

It would be dangerous to clip the display of numbers; for example,

millions might appear to be thousands. Therefore, if an entire number

cannot be displayed, RagTime first tries to display it in exponential form

and, if this is not possible, fills the cell with �#� characters.

None of this has an effect on the contents of the cell; only the dis-

play is affected. Cell references in formulas return the correct contents.
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Entering the �Sum� Formula
7. Click in cell B17.

8. Enter the �Sum� formula. Select Sum from the function list and drag

over cells B5:B16.

9. Press Enter or click +. The result appears in cell B17.

Entering the Functions Min, Max, and Average
10. Click in cell B18 to enter the formula for minimum sales.

11. Select Min from the function list and drag over cells B5:B16 as

before

The functions Sum and Min both use the argument List. As you can

gather from the description in the Functions dialog box, the function

Min(List) finds the smallest value in a list and returns it in the cell in

which the formula is entered, in this case, B18.

12. Proceed in the same manner to determine the maximum and

average values of cells B5:B16. The function for the maximum values is

Max and for the average of all values, Average.

Be careful when dragging over cells that you do not inadvertently

include too many cells, which will give you wrong results.

To avoid this error, it may be helpful to drag from bottom to top,

that is, from B16 to B5. For RagTime, the direction makes no

difference. The table should now look something like this:
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B / A When dragging over cells, be careful not to include too many

cells by mistake. This would generate unwanted results.

To keep this from happening, it may help to select the cells from bottom

to top, i.e., from B16 to B5. RagTime doesn�t care how you make the

selection.
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Copying Formulas
13. You could repeat this procedure for the other

columns. It is faster, though, to copy the formulas

into the cells to the right. To do this, select the

four cells containing the formulas (B17:B20).

14. Choose Edition>Copy from the menu bar.
15. Select cells C17:D20.

16. Choose Edit>Paste

from the menu bar.

The results appear in columns C and D.

RagTime did not, as you may have expected, transfer the values

from column B, but adapted the formulas to the new location. See for

yourself. Click in cell D20. Open the Formula palette by clicking the

abacus and check the formula.
The formula for the average in cell D20 refers correctly to the cells

above it, D5:D16.

Formatting the Table
Next, the appearance of the table ought to be polished. First, all numbers

should have thousands separators and two decimal places. The titles

and the calculated cells should have bold typeface.

Lines should set off the sales numbers from the titles above and the

results below.
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B / A Formulas can also be copied using the fill-in feature. You

may need to delete the results in columns C and

D to do so.

1. Select the four results from B17 to B20.

2. Move your pointer to the selection�s right handle until it changes to

a new spreadsheet pointer with a plus sign.

3. Keep your finger on the mouse button and drag the handle two

columns to the right.

The results appear in columns C and D. What happened is that

RagTime copied the

selected formulas,

pasted them into

columns C and D, and

calculated the results.

Instead of clicking the Abacus, you can open the Formula palette

by choosing Windows>Palettes>Formula  from the menu bar. There

you will find more palettes; it�s worthwhile to experiment with them!
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Determining the Value Format
17. To select the numbers in cells B5:D20, click in cell B5, hold down

the mouse button and drag diagonally to cell D20.

18. Choose Format>Value Format>1,234.50 from the menu bar.

This is the result:

Formatting Headings
19. Select cells A1:D4. Choose Format>Style>Bold from the menu

bar and repeat the procedure for cells A17:D20.

20. Select cells A3:D3. Choose Format>Alignment>Right Aligned,

and repeat the procedure for cells B4:D4. The result looks like this:
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A You can edit or create new value formats by choosing Windows>

Auxiliaries>Value Format Editor. By the way, formats follow a pre-

defined sequence in their relation to one another. It�s important to know

it when you want to create your own formats: fill formats>line for-

mats>character formats>character style sheet formats. For example,

character style sheets can use the aforementioned formats, but a fill

format cannot use a character format.

A RagTime automatically recognizes a number of value formats. If you

only have a few numbers to type, it thus makes sense to enter the unit

along with the number. Let�s see how this works in practice:

1. Create a new spreadsheet and enter the following values one

underneath the other: "$_23.4", "$_234.10", "EUR_87.9",

"234.10_¤" and "£100" (please note that in the last example, you

may not enter a space between the number and the pound sign, whereas

you must leave a space between all other currency indicators and their

numbers).

2. RagTime converts all the preceding entries into number entries,

combined with their respective currency symbols. This means the cells�

text entries have been replaced by numeric values, combined with

currency formats. However, the layout shows the entry along with

currency designations and the properties applicable to the different

currency formats (decimal and thousand separators, etc.).
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Does row 17 look like this?

If so, columns C and D are merely too small, which is indicated by

the symbols �###.� Widening the three columns will solve the problem.

Inserting Rows
As you saw in the illustration of the table at the beginning of

thisexercise, the first four rows are separated from the sales figures by a

gray row. The same applies to the last four rows. To achieve this effect,

you must first insert an empty row.
21. Click the title of row 5. The entire row is selected.

Choose Spreadsheet>Insert Rows from the menu bar and click

Insert. A row is inserted above row 5, becoming the new row 5. The rest

of the table is moved down, and the formulas are automatically adapted

to the new situation.

Insert a blank line in the lower part of the table by selecting row 18,

which contains the sums, and choosing Table>Insert Rows.
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A As always, it�s best to format colors using style sheets. If, for

example, you would like to change a shade of gray, making this change

just once in the style sheet causes all occurrences within the style sheet

to take on the change. Before creating a color style sheet, it makes sense

to choose an appropriate color space. In RagTime, color style sheets are

defined under Windows>Auxiliaries>Colors.The following window

opens up when you make this choice.

New color style sheets are generated using the Create button in the

Color menu and assigning the finished color, or by entering values for

the color components. Furthermore, the properties Process Color/Spot

Color/Overprinting/Not Overprinting and, of course, the Color

Model itself are also set in this manner. Please note that the split color

preview area will continue to display two color values until you click the

green checkmark. This click validates the final values for the color style

sheet.

To create a color style sheet for the adjoining

example, click on Create and select an appropriate

shade of gray from the Color menu. Choosing

Other... opens the operating system�s Color Picker

that allows you to do some additional fine-tuning.

Click the green checkmark as soon as you have set

the color and other properties. The left side of the

color editor now displays your color style sheet with

a name that reflects the color model�s breakdown by

color. You may replace this technical name with one of your choice by

editing it as you would an entry in a list view. 

To assign a color style sheet to an object, simply drag and drop the

color style sheet onto the selected object, or pick the corresponding item

from the Format menu.

Since different color models have color spaces of varying sizes, a

color may change its appearance on screen and on paper as it flows from

one color space into the next. The reason colors sometimes take on a

slightly different appearance  in RagTime lies in their color space�s

properties. This isn�t a RagTime quirk. 

B / A If you work a lot with spreadsheets, you can access related

commands such as Insert Rows, Sort, etc. from the Spreadsheet

Commands palette as well.
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Coloring Cells
22. Select cells A5:D5.

23. Choose Format>Color>(Gray), for example. Continue in the

same manner with cells A18:D18.

Reducing Row Height
24. To change the row height, position the pointer on the separator line

between row headers 5 and 6. Notice that the pointer changes its form.

25. Press and hold the mouse button.

26. Move the pointer slowly upwards. A ghost line helps you set the

height of the row as you wish. 

27. Release the mouse button. RagTime adjusts the height of the row.

Continue in the same manner with row 18.

The table is now finished and may be printed�

Wrong Number�Now What?
You receive a phone call. The message is that unfortunately two

digits were reversed when the numbers for the sales representative

Hanson were entered. In the month of June, the figure was not 26,500

but 25,600. A rare case? Not at all! But here the spreadsheet shows its

strength, namely, the possibility of making later changes to correct errors

like this one.
28. Click in cell D11 and overwrite the wrong number with 25600.

Before you press Enter, check the four results at the bottom of the table.

Now press Enter. In a flash, RagTime brings all the values up to date.
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Reversed characters are among the most common typing errors.

Therefore, RagTime offers a special command to correct them without

changing the position of the insertion marker:

If the insertion marker is at the end of a word, you can reverse the

order of the last two characters by choosing Edit>Swap Two Charac-

ters.

If the insertion marker is between two letters in a word, these will be

swapped.
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The Table Gets a Graph
Often numbers alone are difficult to interpret. Charts, or graphs, can

help emphasize differences and demonstrate trends in numerical data.

With its many graph variations, RagTime presents such an abundance of

formatting possibilities that you have an appropriate type of diagram for

every purpose.

The steps for creating a graph

> Select and copy values in a spreadsheet.

> Draw a rectangle and give it the contents type graph.

> Insert the data in the graph.

> Pick a graph type from the gallery.

> Format the graph.

You will now apply these steps to the example �Sales Figures.�
29. Select cells A22:D22 (Average Volume).

30. Choose Edit>Copy from the menu bar.

31. Draw a rectangle under the table, for example.

32. Install a graph in the selected rectangle with Drawing>Graph

Type>Graph.

33. Click in the graph. The graph tool appears in the tool bar.

34. Choose Edit>Paste from the menu bar.

35. In the Gallery dialog box which appears, you can pick an

appropriate graph type from the hundreds available. 
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36. In the gallery, select the column graph from the panel Basic

Charts and confirm the selection with OK.

37. The dialog box New

Category Series appears.

Confirm the settings with OK.

38. The following graph appears.

You can edit the graph further. For example, a title and the legend

are missing. Experiment with the Arrangement panel in the Graph

Information dialog box (Graph>Get Info>Arrangement).

You can change all other settings in the information dialog box, as

usual in RagTime 5. Select elements in the graph by clicking and open

the dialog box. In most cases, you can combine selecting and opening in

one double-click.

In complicated graphs with numerous elements, it is sometimes

difficult to hit a particular element with the pointer. For this reason, you

can also select all elements and their parts in two menus in the tool bar

and in the Graph Information dialog box.
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You can drag data from the spreadsheet directly into the graph.

When you move the pointer to the border of the selected cells, the move

pointer appears.

Press the mouse button and drag the cells into the graph. A ghost

rectangle represents the cells being dragged. When a pattern appears in

the graph, release the mouse button to make the data available to the

graph.

RagTime fits the axis labels in the space available. If you have drawn

a somewhat smaller rectangle, the labels will appear at other intervals.
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Try to put labels on the category axis using the following procedure:

Call up the Information dialog and pick the Categories panel. Click in

the field  Category Titles to the right of the Abacus. Enter the following

names �Gainsborough�; �Williams�; �Hanson�; as a list using formula

orthography (that is, with quotation marks and semicolons). Confirm

your entries by clicking OK.

Feel free to experiment with other settings.
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When you want to enter formulas in dialog boxes, you can type them

directly in formula entry fields. Frequently the formulas contain spread-

sheet cell references which you can create more easily by clicking the

cells, just as you do when working with the formula palette. Click in the

appropriate formula field to the right of the Abacus and then click or

drag across the desired cells in the spreadsheet. A ghost border marks

the cells. When you release the mouse button, the reference is entered in

the formula field.

If the cells are hidden by the dialog box, you can drag the box aside.

A Did you know that you can also select individual data points from a

row and format them differently from the other entries? The first time you

click on a row, you select the entire row. The second click lets you select

an individual data point.You can then assign formats to the data point by

using the Format menu.
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4.5 Exercise 4: Packaging Sells Products�Designing a Package

In exercise 4, you will get to know the �drawing� component. You

will learn to 

> differentiate between drawing in a layout component and drawing in

a drawing component,

> draw with various tools,

> save work by duplicating objects,

> group objects.

The completed drawing, prior to decoration, should look similar to

the illustration. For orientation purposes, the drawing objects are

numbered. Identical objects have the same number.

The drawing represents the plans for a package for small items such

as antifog cloths, thin insulation blankets and so on, like those you find

on the display stands of a car parts store. 

Drawing in Layout and in Drawing Components
Thus far you have used drawing tools to draw various objects on a

layout page. These were then used as containers to which you assigned

particular types of contents. We call this kind of drawing �drawing in a

layout.� Drawing in a layout is mainly for structuring pages and making

containers available for components such as text, pictures,

spreadsheets, and so on.

In addition to components like spreadsheets or texts, there are also

drawing components in which you can draw with the same tools as in

layouts. In contrast to layouts, drawings are not bound to a particular

page size. We call this kind of drawing �drawing in a drawing

component.� Drawing in components is primarily for creating

illustrations, for example. Such a drawing may be installed in a layout in

numerous places, if desired, and may be easily scaled and positioned.

Beginning with a Drawing Component
Choose Start>Programs>RagTime>RagTime or your favorite

method to start the program. Choose File>New Beginning With>

Drawing. A window with a drawing opens, and the tool bar contains the

drawing tools.

Don�t forget to save! Name the file �Package Design�; this name will

appear in the window�s title bar.

Drawing in a drawing
component

Goals

< P
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Drawing in a layout
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object width height

➀

in

2.5
in

2.25
➁

➂

➃

➄

2.5
2.5

1.75
4.25

0.5
0.5

4.25
4.25

➅

➆

➇

➈

2.5
2.5

0.5
0.5

0.5
0.5

0.5
0.5

➉ 1.5 0.25

New Beginning with�
Please note that RagTime 5 does not have different types of

documents for drawings, layouts, spreadsheets, and so on. With the

command File>New Beginning With>�, you merely specify what to

start with. You can add further components at any time by choosing

Windows>New Component>� and combine them with the existing

components without starting a new document.
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RagTime provides you with a number of very powerful commands

and drawing tools. They are located in the menu bar and the tool bar,

which you already know from creating drawing object in the previous

exercises.

We will draw the package design in three steps.

> Drawing the rectangles (tool: rectangle)

> Drawing the polygons (tool: polygon)

> Drawing the �punch out� (tools: rounded rectangle and oval)

Drawing the Rectangles
The rectangles are the objects numbered ➀, ➁, ➂, ➄ and ➅ in the

package design.

1. Choose the rectangle tool from the tool bar.

2. Draw rectangle ➀ approximately as it appears in the following

illustration. The eight handles are visible.

3. Choose Windows>Palettes>Object Coordinates from the

menu bar. The Object Coordinates palette opens, showing the

coordinates of the selected object.

Page boundary 
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RagTime 5 assumes that the objects which you draw on a page will

serve as containers for displaying other components. Therefore, RagTime

draws the objects with the line style sheet Container Border which

makes sure that the lines are not printed.

In a drawing component, objects are generally used as rectangles,

circles and so on, so RagTime applies to them the line style sheet

Normal Line, which causes the lines to be printed.

Please note that these are just default settings. Of course you can

use any line style in layouts and drawings. And naturally, you can install

components, for example texts or spreadsheets, in the objects contained

in a drawing. You can install, for example, pictures or spreadsheets in

texts, or drawings or audio files in spreadsheets�

You can change your preferences for line styles and style sheets

used in layouts and drawings in the Lines panel of the dialog box opened

by Extras>Document Settings.

B / A To place a frame with a printable border around a text block,

please proceed as follows:

1. Draw a rectangle with Text as the content type and write a few

words in it.

2. Double-click the container border and select the Drawing

Information>Lines panel. Under Style Sheet, instead of Container

Border, select Normal Line, for example, and increase the line width to

0.75 pt. Click Apply. This creates a clearly visible text frame.

3. Click the Objects panel and enter 0.5 in in Distance to Border.

Confirm your entry by clicking OK. There text now has a corresponding

distance to the container border.

This procedure allows you to create text frames like those used in

newspapers and magazines, for example.

You can also edit the coordinates in the Coordinates panel of the

dialog box Drawing>Get Info. In the corresponding fields, you will find

the same icons used in the palette, so if in doubt, you can use the label

in the panel to determine the meaning of an icon. Palettes are inten-

tionally kept small so you can keep them open without their disturbing

your work too much.
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4. Set the width of rectangle ➀ to 2.5 in. and the height to 2.25 in. 

Leave the palette open; it will serve you well later. If it is in the way,

drag it to the side.

You can create rectangle ➁ in the same way. However, you can

simplify the job substantially by duplicating rectangle ➀.

5. Select rectangle ➀ and use the command Edit>Duplicate. You get

a slightly offset duplicate of the rectangle. Because object ➁ has a

slightly lower height than object ➀, you must correct the height to 1.75

in. in the palette.

As you see, duplication is faster than drawing a new rectangle. This

is particularly true when the original and the duplicate are identical or, as

in this case, very similar.

6. Move the modified rectangle to the position of rectangle ➁. Be sure

to leave space between the two rectangles for a fold. You drawing should

now look something like this:

Next you need rectangle ➂. Since this rectangle occurs twice in the

folding box, you need to create one and then duplicate it. But even the

first step in production can be simplified. You can duplicate rectangle ➁

and change the height.

7. Select rectangle ➁ and use Edit>Duplicate. You get a slightly

offset duplicate of the rectangle. Because object ➂ has a height different

from the original, you must change the height from 1.75 to 4.25 inches in

the palette.

8. Now move the modified rectangle to the position of rectangle ➂. It

may be wise to reduce the screen�s display scale temporarily under

Windows>Display Scale. 

Fold
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In the upper part of the Object Coordinates palette (and the

corresponding part of the Coordinates panel in the Drawing Informa-

tion dialog box), you see the position of an object. That is normally the

middle of the object, which is marked by a circle in selected objects. If

you change these numbers, the object is moved to another position

without changing its height or width. With the buttons, you can switch

the display of the two position values among left/middle/right and top/

middle/bottom.

In the next part of the palette, you can see the coordinates for the

borders as well as the height and width of the object. These values are

mutually dependent. For example, if you enter a new value for the right

border, the width changes, and vice versa.

B / A Here�s an alternative way of duplicating objects: Press Ctrl

and drag the active object you want to duplicate to its new position. This

creates a duplicate in the new position, leaving the copied object un-

changed in its original position. Holding down the Shift key (s) while

duplicating ensures that the duplicated object can be moved only

vertically or horizontally.
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9. Duplicate the rectangle with Edit>Duplicate and position the

duplicate to the left of the original.

10. Now draw rectangle ➄. Watch the Object Coordinates palette

while drawing and try to get the correct width (0.5) and height (4.25 in.)

immediately. If you are not successful, enter the values in the palette.

11. Make a duplicate of rectangle ➄ and move it to the proper location.

12. Proceed in the same manner for both rectangles ➅. Make duplicates

here as well. Your layout should resemble the following illustration:
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B / A A quick way of enlarging a section on your screen when is to

make use of the Magnifying Glass tool. Mark the section you wish to

enlarge by dragging open a frame around it. The smaller the frame, the

greater the enlargement. 

Alternatively, you can rapidly enlarge the display scale by holding

down the Ctrl and 9 keys simultaneously. Pressing Ctrl  + 7 reduces the

size.

A Do you want to have several screen display scales at the tip of your

fingers? Simply assign the corresponding menu commands to the

function keys of your choice. For example, you can program the function

keys F5�F8 with display scales of 25%, 50%, 150%, and 200%,

respectively.

1. Choose Extras>Commands. This opens the Commands window

which lists all of RagTime�s commands on the left.

2. Choose the group of commands called Window Commands>

Display Scale from the category list. There you will find a complete list

of scaling options accessible under the Windows>Display Scale menu.

3. Select the 25% entry and click Create. The Enter Shortcut screen

message appears.

4. Choose the F5 function key for our example.

5. RagTime records the function assigned to the key under Keyboard

Accelerators.

6. Follow the same procedure for the remaining display scales. If a

command already has a keyboard shortcut assigned to it, both the new

and the old shortcuts are displayed.

7. Once you have finished creating shortcuts for the display scales, exit

the dialog by clicking Close.

B / A If you want to use the same drawing tool repeatedly, you

don�t have to select it in the tool bar each time. While holding down the

Ctrl key, simply click where you want to draw the next object.
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Drawing the Polygons
The polygons are the objects numbered ➃, ➆ and ➇ in the package

design.

13. Select the polygon tool from the tool bar.

14. Begin drawing polygon ➃  at an end point; click once each time you

change the direction of the line. Orient yourself with the rulers on the left

and upper sides of the window or on the Object Coordinates palette.

They aid in creating symmetric angles. To make sure that the polygon is

closed, conclude by clicking the first point once more.
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A RagTime has a nifty feature for creating frequent angles such as 45°:

If you hold down the Shift key (s) while drawing with the Polygon tool,

all angles are multiples of 15°. This way, you can easily create a 45°

angle.

Should you want to draw an open polygon, end the drawing with a

double click ( ") to set the last point, or if you have already set it, end

with Ctrl + ' on the last point.

The last polygon point is slightly magnetic to make it easier to hit.

You can edit polygons and Bézier curves by selecting them and

pressing Enter. You can also " them or choose Drawing>Edit Curve.

The Curve Editing palette can be used to manipulate polygons and

Bézier curves.
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gon segment

 pointer
15. Verify in the Object Coordinates panel that the the width of the

polygon is 0.5 inches and the height, 4.25 inches.

The two instances of object ➆ differ not in form, but only in position.

The same is true of the four instances of ➇. Therefore, you will duplicate

the objects as in other cases and get them in the correct position by

rotating and mirroring them. RagTime provides commands for rotating

and inverting drawing elements under Drawing>Transformation and

other places. We will start with object ➇.

16. Select the polygon tool from the tool palette.

17. Using the Magnifying Glass, enlarge the display

scale by dragging open a rectangle around the area

you�re working on. Draw object ➇ as it appears in the

illustration.

18. Verify in the Object Coordinates palette that the width and height

of the polygon are both set at 0.5 inches.

19. Choose Edit>Duplicate three times from the menu bar. This

creates three duplicates. 

20. Click one of the duplicates. The handles appear.

21. Choose Drawing>Transformation>Flip Left<�>Right from the

menu bar.

22. Reduce the display scale if necessary. Move the polygon to its place

in the upper right corner.

Poly

Draw
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The individual points of a polygon are marked with handles which

you can select by clicking and move with the mouse. For detailed work,

you can move selected points with the arrow keys. Hold down the Ctrl

key at the same time to move the points in larger steps.

You can end the editing of a curve by selecting another object or

pressing the Enter key.

Polygon in edit state with

a selected point
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23. Proceed analogously with the other two duplicates of polygon ➇.

Use the other commands for transforming drawing objects as well. Move

the transformed objects to their places. The result appears below:

24. Select the polygon tool from the tool bar.

25. Draw polygon ➆ as described above. The result should look like

this:

26. Check in the Object Coordinates that the width of the polygon is

2.5 inches and the height, 0.5 inches.

27. Create a duplicate with Edit>Duplicate.

28. Select the duplicate and use Drawing>transformation>Flip

Top<�>Bottom.

29. Move the polygon to its place.

Now you have finished the sides (rectangles ➀ through ➅) and the

flaps (polygons ➆ and ➇) of the package design.
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Drawing the Punch Outs
Because our package is supposed to hang from a display stand, a

punch out is planned in the design (objects ➈ and ➉). First, increase the

display scale by using the Magnifying Glass tool to drag open a

rectangle around the area you�re working on.

30. Select the Oval tool from the tool bar.

31. Draw an oval with a width and height of 0.5 inch in rectangle ➀, as

shown for object ➈ in the example. Check the size in the Object

Coordinates panel. 

32. Select the rounded rectangle from the tool bar.

33. Draw a rounded rectangle in rectangle ➀, as

shown for object ➉ in the example.

34. Check the size in the Object Coordinates panel (width 1.5 in, height

0.25 in).

35. Move the objects together so that they look

roughly like this:

Changing the Stacking Order
The rounded rectangle, which you drew last, is in front of the circle.

In the finished drawing, the order should be reversed.

36. Select the circle by clicking it. 

37. Choose Drawing>Stacking Order>Bring to

the Front.

Aligning and Grouping the Drawing Objects
In the following steps, the two objects will be precisely centered and

grouped in a single object.

38. Select objects ➈ and ➉. To do this, click object

➈ and then, while holding down s, click object ➉.

Handles appear on both objects.
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If you want to draw an object with equal height and width, of course

you can draw very carefully or enter values in either the Object

Coordinates palette or the Drawing Information dialog box. But it�s

simpler to hold down the Shift key (s) while drawing. The Rectangle

tool functions as a Square tool, the Oval tool, as a Circle tool, and so

on.

B / A If you want to select several

objects together, you can enclose them in a

box with the pointer. Only objects which

are completely enclosed are selected. Be

careful not to click in an object.

Another way of doing this is to drag open a selection frame that

touches all the objects with your mouse while holding down the Shift (s)

and Ctrl keys.
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39. Open the palette Windows>Palettes>Drawing Commands. The

following palette appears:

40. Click the center button. The objects are now

centered.

41. Choose Drawing>Group from the menu bar or use the

corresponding icon from the Drawing Commands palette. RagTime will

now treat the two drawing objects as one object.

42. Move the �punch out� group to its position in rectangle ➀. Click any

member of the group and drag. In the Object Coordinates panel, set the

value of the horizontal middle of the group to the same value as that of

rectangle ➀.

43. Select and duplicate the�punch out� group. 

44. Move the duplicate to its position in rectangle ➁. Take care that

both punch outs are the same distance from the fold.

If you wish, you can add text and illustrate the package with a

picture. Then print the drawing and cut it out to test its precision and

usefulness.
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The command Drawing>Arrange Objects provides a clever way

to arrange objects. In a dialog box, you can make precise settings for

their arrangement.

Draw several objects, select all of them, and try out the various

possibilities.
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4.6 Highlights from This Chapter

General
> Components are the important elements of a RagTime document.

> Components may be texts, pictures, spreadsheets and graphs,

among others.

> Each component, when active, has its own set of tools in the context

sensitive tool bar.

> Each component, when active, has its own menu in the menu bar.

> Every component has its own information dialog box.

> The information dialog box contains all the characteristics of an

object.

> Drawing objects are created with drawing tools in the tool bar.

> Drawing objects can have virtually any form.

> Drawing objects may be moved, enlarged, reduced, rotated,

mirrored, duplicated or deleted.

> Several drawing objects may be grouped as a single element.

> Drawing objects may be protected against moving.

> Drawing objects may be used as containers for components. You

can install a component via Drawing>Container Type>�, by

using the Content Type tool, or by preselecting the content type

before using the corresponding drawing tool.

> The layout of a document is structured with drawing objects and

installed components.

Concerning Exercises 1 to 4
> Text may be formatted in various ways.

> Frequently used formats are character formats like font, font size

and font style. The most important character format commands are

grouped in the first part of the Format menu.

> Additional formats are paragraph formats like margins, tabulators

and alignment. The most important paragraph format commands

are grouped in the second part of the Format menu. 

> Never use the blank space key to align text.

> Spreadsheets consist of rows and columns. Columns are normally

named with letters and rows with numbers (for example, column C,

row 9).

> Row height and column width can be adjusted as necessary.

> The intersection of a row and a column is called a cell.

> Every cell may be uniquely defined with the names of its row and
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column, (for example, C9 designates the cell at the intersection of

column C and row 9).

> Values or formulas may be entered in cells.

> A cell value may be a text, a multiline text, a number, a calendar

date with time, or a time span. 

> Formulas are created by joining cell addresses and constants using

operators (A7+B7*F17-1,5).

> Formulas are entered and edited in the Formula palette.

> RagTime provides hundreds of functions (for example, the Sum

function) in various fields including business, mathematics,

statistics, and so on, which are available in the Functions dialog

box.

> Copying cell contents can speed up work with spreadsheets

substantially.

> Copying cell contents can speed up work with spreadsheets

substantially. Identical cell contents and data sequences can be

duplicated or completed in the spreadsheet itself by selecting the

cell entries in question and dragging the selection handle over the

target cells, or by using a dialog accessible via Spreadsheet>Fill

Row... 

> The presentation of texts and values in cells can be individualized

with formatting.

> Numbers can be represented in graphs. RagTime offers hundreds of

graph types.

> Numbers in spreadsheets can be used in graphs.

Concerning Exercises 1 to 4122
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5.1 Creating a RagTime Stationery Pad

Forms used in offices often come as gummed pads from which

individual pages may be torn and filled out. RagTime has long been

known for its sophisticated �form� feature which simulates such pads.

This feature enables you to not only let your creative juices run free in

designing the structure and order of stationery pad pages, but also to

manage the pipelines to determine how and when pages are auto-

matically torn off.

RagTime stationery pads thus fulfill a dual function: they are both

time-saving and flexible. Repeated entries automatically flow into their

predetermined components. You can configure pipelines and specify

special rules to generate a reproduction mechanism when you want

flowing text to generate a certain type of new page.

> In this section, we will look first at an example which uses only

pipelines which can be drawn between two containers.

> Next, you will see how to create a simple stationery pad in RagTime.

In the accompanying exercise, we will show you what circular

pipelines are and what role they play in the construction of more

complex stationery pads.

What Are Pipelines
A pipeline is a connection between two containers which enables

the contents of one container to flow into the other. It makes no

difference if the containers are on the same or different pages.

Beginning a New Document
Choose Start>Programs>RagTime>RagTime or your favorite

method to start the program. If RagTime is still running since the last

exercise, then choose New Document from the File menu. A window

containing a layout opens, and the tool bar contains the layout tools.

Delete the active standard rectangle using the Delete key. (It has a

mechanism for creating new pages which would get in our way during

this task.)

Pipelines on One Page
Now design a layout to match the following sample, with three

rectangles, two for text and one for a picture (Drawing>Contents

Type>Text/Picture). The picture of the car is located in the folder

�RagTime\Examples\Training.�

Goals

5 STEP TWO: RAGTIME WELL PLANNED
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Only the contents types texts and spreadsheets, which can actually

flow, may be distributed with the aid of pipelines in multiple containers. 
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The text in the three text containers changes according to the car

model that you want to describe. It may be longer or shorter, depending

on the car. Therefore, you need a dynamic connection between the text

containers which responds flexibly to differing lengths of text.

Sometimes all three text containers are needed, and sometimes only

containers A and B. Pipelines are the ideal solution in such a situation.

Installing Pipelines
1. Choose vertical pipeline from the tool bar.

2. Move the poin-

ter over container A.

The pointer changes

its form.

Text

Picture

Text

Text
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Three pipeline tools are available. Vertical pipelines can be used for

texts and spreadsheets, and horizontal pipelines only for spreadsheets.

You can cut pipelines with the third tool.
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3. Now click in container

A and, holding down the

mouse button, drag the

pointer to container B. A

pattern appears when you

hit the container. You can

now release the mouse

button. 

4. Now make a pipeline between Containers B and C in the same way,

and you are done. All three containers are connected with each other.

This means that when

you write in container A,

and it is full, the text flows

into container B and from

there into container C. If you

then delete part of the text

in container A or B, the text

flows back. Try it out.

From Document to Stationery Pad
Assume that you will always want to use this design in the same

form. Then you should make a stationery pad out of the document.

Before doing so, you should empty all components so that you don�t

have to repeat this work every time you tear off a copy.
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If you want to check pipelines, you can display them on the screen

with the command Windows>Show>Pipelines.
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5. Choose File>Save As. The following dialog box appears:

6. Check RagTime 5 Stationery Pad (*.rtt). Name the document �Car

Description� and click Save. The document will then be saved on your

hard disk as a RagTime stationery pad.

The Windows icon for a RagTime stationery pad shown here in the

left margin appears.

Tearing Off from a Stationery Pad
7. Choose File>Open Document and select the stationery pad �Car

Description� in the window that opens. Notice that the Open button is

now labeled Tear Off. The following window appears:

The document has the name of the stationery pad extended with the

current date. You can complete the document with a new text and picture

and give it a name of your choice when saving it.
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When you put a stationery pad in the folder �Stationery Pads�,

RagTime provides a special service. The next time you start RagTime, you

can select the pad from the File>New Beginning With>� menu and

tear off a copy.
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rhead picture
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5.2 Exercise 5: Our Business Letter Needs More Pages

Remember our business letter from exercise 1? We wrote a bid for a

customer, unfortunately under pressure, because the letter had to go out

fast.

In this exercise, we will assume that you have more time to design

the document, and what is more important than to facilitate quick,

positive contact with a customer? When you do so in writing, for

example, in a letter or a fax, RagTime stationery will serve you well.

Our present letter consists of one page with a number of

components and has the following structure:

Lette

Lette

Date

Addr

text

Bod

Foot
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What the Stationery Pad Has to Do
What you urgently need is a second, a third, or more pages in case

the bids become more extensive.

The requirements: The RagTime stationery pad must consist of

> a first page like the existing one,

> a second page having a different design, which may be appended as

needed, and

> additional pages having the same design as the second page, which

may be appended as needed.

This is a classic situation for a RagTime stationery pad, that is, a

form with capabilities that satisfy complex requirements. The document

with a second page could look like this: 

Designing a Layout
Since the first page already exists, in this exercise you need only to

design the second.

We will now make use of a standard procedure RagTime uses to

open new documents and that we already used when creating the first

version of our business letter�probably without your noticing it. 

This page consists of two texts, one for the body of the letter and

one for the header with the recipient�s name, the date, and the page

number.

Goals
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Appending a Page
1. Open the document �Business Letter� from exercise 1. Delete the

texts from the address, the date, and the body.

2. Choose Extras>Add Page  from the menu bar. The second page

�inherits� the standard rectangle from the first page, which you can tell

since the rectangle is not as far up as usual. Drag the frame vertically so

that it matches our example. Then draw the rectangle for the header on

page 2. Align the header and body if necessary (using Drawing>Align).

Adding Text to the Letterhead
3. Select the rectangle for the letterhead on the second page and

choose Drawing>Contents Type>Text.

4. Click in the letterhead container and type �Recipient�s Name� in the

first line and �Date� in the second as reminders that this data must be

placed here later. Choose a smaller font size if needed.

5. In the third line type �Page� and type a blank space after it.

6. Choose Edit>Insert Special Text>Page Number from the menu

bar. The number �2� appears. Type another blank space. Type the word

�of� and then another blank space. 

7. Choose Edit>Insert Special Text>Number of Pages from the

menu bar. The number �2� appears again. The letterhead of the second

page is finished.

Completing a Circular Pipeline
In RagTime, circular pipelines are used to add pages. Here, it

employs the business letter�s replicating mechanism to ensure that when

a new page is added, it always has the same structure. You create a

circular pipeline by drawing a pipeline inside a single container, in this

example, the one for the body of the letter on the second page. The

following steps are necessary:

8. Select Vertical Pipeline from the tool bar.

9. Drag a pipeline within the body container on the second page.
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A The commands Edit>Insert Special Text>Page Number and >

Number of Pages are shortcuts for entering formulas in text com-

ponents. Like many other things in RagTime, page numbers are

calculated with formulas and functions. You can also enter a formula in a

text component in the usual way. You will see how to enter formulas in

the following exercises.

If you so wish, you can view the page number here as a formula.

Select the page number which you inserted and open the Formula

palette by clicking the abacus in the tool bar. You should see the

following formula in the palette:

If the value expressing the number of pages is selected, the formula

should look like this:
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10. Confirm the dialog

box by clicking Create.

11. Render the exist-

ing pipelines visible by

going to Windows>

Show>Pipelines. The

circular pipeline symbol appears in the middle of the container. It

indicates that the second page will be added as the third, fourth,

fifth, and so on, as needed.

Checking Pipelines
We generated the body on the second

page by choosing Extras>Add Page, making

page two �inherit� the standard rectangle from

page one. The advantage here is that either

page is �aware� that the other exists, which

allows for text to flow through a pipeline from

the first into the second rectangle, if necessary.

12. Take a moment to think about what the

stationery pad we�ve generated is capable of:

Pages one and two are connected by a black

line which represents the pipeline. On the

second page, you can see the circular pipeline

displayed as a circle tagged onto the end of the

line. It, too, ensures that new pages with the

same characteristics can be added.

You will learn how to lay pipelines

connecting several containers in empty layout

pages at the end of this exercise.

Tear-Off Settings
When you tear off a copy from a stationery pad, normally the entire

document is duplicated and the duplicate is opened. In this case,

however, only the first page should be torn off initially. Additional pages

should be added only as needed.

13. Choose Extras>Document Settings. A panel dialog box opens. In

the menu at the top of the box, you can specify whether you want to

change the settings for New Documents or the Current Document.

Choose the Current Document.
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If you want to install pipelines between objects which do not yet

have any contents, a pipeline symbol is shown in the middle of each

object. When the connected objects are given contents, the symbol

disappears and the contents are visible. You can prepare objects with

pipelines in , for example, stationery pads and later decide if you want to

install text or a spreadsheet.

If you want a screen display of the pipelines to objects having

contents, choose Windows>Show>Pipelines.

If you move the pointer over a pipeline close to the pipeline terminal

symbol, the pointer changes to a �pedestrian.� If you then click, the

other end of the pipeline is displayed. If necessary, the window display is

changed.
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14. Select the Document panel, turn off Torn Off Completely and click

OK. Now only specially marked parts of the document will be torn off. In a

layout, that is normally the first page.

Saving the Document as a Stationery Pad
The following procedure is the same that you performed in an earlier

exercise for the simple stationery pad.

15. Choose File>Save As�. The Save dialog box opens. 

16. Name the stationery pad �New Business Letter� and select

�RagTime 5 Stationery Pad (*.rtt)� as the document type.

17. Click Save. The document is saved on your hard disk as a RagTime

stationery pad.

Tearing Off a Page from the Stationery Pad
18. Choose File>Open Document and select the stationery pad �New

Business Letter� in the dialog box. Note that the Open button is now

called Tear Off.

19. The document has the name of the stationery pad extended with the

current date. You can complete the document with current data and

rename it when saving it.

Appending Pages
Pages may be added in several ways to a layout torn from a

stationery pad.

> You can choose the command Extras>Add Page.

> The stationery may add a page automatically. If a container has a

pipeline to a container on another page, when the first container is full,

the  other page is torn from the stationery pad and inserted in the current

layout.
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Document Date
You will find the document date in the Document panel of the

command Extras>Document Settings. RagTime sets it when creating

a new document. Afterwards, it will not be changed automatically, but

you can change it manually.

You can access the document date with a formula or by choosing

Edit>Insert Special Text>.... from anywhere within the document. It

is practical, for example, to use this date to date letters in a letter

stationery pad. 

RagTime enters the correct date when tearing off a copy from the

stationery pad, and the letter�s date corresponds to the day on which you

created the document.

1. Click in the date area in the second reference line.

2. Choose Edit>Insert Special Text>Document Date (Short).

RagTime enters the date. 

Alternatively,

since RagTime uses formulas internally to insert document dates, you

can also do so with a formula. 

1. Click in the date area in the second reference line.

2. Open the Formula palette by clicking the Abacus in the tool bar and

enter the function DocumentDate.

3. Confirm the formula by pressing Enter. The date appears.

Now, if you save the document as stationery and later tear off a

copy, your letter will automatically have the correct date (if the clock in

your computer is correct).

A Entering a date with a formula may require an additional step to

generate the desired result. Nevertheless, this method is more versatile

in terms of usability. It makes formulas available which you can use to

insert the current date (not the document date) or the value of the

current calendar week anywhere in your document. Just take a look at

the range of available functions in the Functions dialog!
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>

> If the container in the stationery pad has a circular pipeline�as is

the case on our page two� the same page is torn off and inserted in the

current layout.

20. Type some text in the body of the letter. When the bottom of the

container is reached, a second page is appended according to the rules

mentioned above.

21. Continue typing until page two is full. An additional copy of the

second stationery page appears as the third page of your letter. Note

that the page number and the total number of pages change accordingly

on both page one and page two.

Pipelines Laid by the User
1. Open a new document and get rid of the default standard rectangle

using the Delete key.

2. Append a second page by going to Extras>Add Page.

3. Position several text rectangles and a rectangle with the content

type No Content on both pages.

4. Lay pipelines between the rectangles in the order of your choice

using the Vertical Pipeline tool. Please note that each rectangle�with

the exception of the first and last one�may contain only one incoming

and one outgoing pipeline.

5. Draw a pipeline from a text rectangle to the rectangle with No

Content. Did you notice? The target rectangle is now ready for text, just

like the others. Keep your eye on the pointer above the target rectangle

or select it to verify its content type, e.g. with the Content Type tool.

6. Finally, have a look at how the text that was entered into the first

linked rectangle flows over into the next one when it runs out of room. If

you intend to fill a rectangle with text only partially, you can force

RagTime to interrupt the text flow within the rectangle by choosing

Format>Start of Paragraph>Next Container.

 Additional Exercise
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Libraries
Whenever an entire page is transferred from one RagTime document

to another, for example, by tearing off a page from a stationery pad, the

source document is registered as the library in the target document. If

some document was already registered as the library in the target

document, you will be asked before the library document is changed. 

This is useful if you want to transfer additional pages from the same

source document, that is, from the same stationery pad to the target

document. You can open the source document as the library with the

command File>Open Current Library. (If no library has been

registered, choose File>Select Library.)

The library document is opened so that it can be read but not

changed. It appears in reduced scale on the right edge of the screen.

You can then drag pages from the library and drop them in other

documents. The sensitive zone within which you can place them is below

the target document. Please note that the target document�s window

must be active first.

If pipelines exist, you will be asked what should be done with the

pipeline and its contents. Since the contents of the container on the page

added from the letter pad are irrelevant, click Pipeline Only.
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ave regularly
5.3 Exercise 6: He Who Sells Must Write Bills

This exercise is a further example of how you can use the RagTime

spreadsheet to produce a genuinely professional invoice.

In this example, you will learn

> how easy it is to format an attractive invoice form,

> how to use spreadsheet features in a �calculating letter form,�

> how to incorporate the formulas which you already know in an

invoice form, and

> how to design a company logo without a lot of trouble.

The Structure of the Stationery Pad
The illustration of the invoice stationery pad on the opposite page

consists of one rectangle with a spreadsheet installed in it and a rotated

graphic text for the simple logo.

Beginning a New Document
Choose Start>Programs>RagTime>RagTime or your favorite

method of starting Ragtime. If RagTime was left running since the last

exercise, choose File>New Document and start with a fresh layout. A

layout appears in a window and the tool bar contains layout tools. Get rid

of the default active standard rectangle.  (It has a mechanism for creating

new pages which would get in our way during this task.) Save the docu-

ment with the name �Invoice Form.�

Preparing a Spreadsheet
In order to fit as much as possible into the invoice, it helps to create

a smaller normal character before creating components.

1. Choose Windows>Auxiliaries>Character Style Sheet Editor.

A window containing character style sheets opens. Select the Normal

Character style sheet and set the font size in the General panel to

Arial, 9 pt.

Goals

< S
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Simple logo

using graphic text

The entire invoice

is created in the

spreadsheet.

Calculation with 

simple formula
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2. Draw a rectangle preset with the Spreadsheet content type that

approximately fills the printable area of the page. After clicking in cell A1,

you should see something like this on the screen:

Because the following steps all are performed on the spreadsheet, it

is more comfortable to work on the spreadsheet in its own window.

3. Choose Windows>Open Component or apply the Open Com-

ponent Window tool. The spreadsheet appears in its own window.
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The title bar of a RagTime 5 window always describes what is

displayed in the window when in Maximize mode. The first part of a title

is always the document name as it appears in the Windows OS. The

second part is the name of the displayed component.

B / A You can also click Open Component to display the current

component in Maximize mode.

When spreadsheet components are displayed in their own windows,

dashed lines show how much of the spreadsheet appears on a page

when printed. When printing, RagTime tries to print the contents of a

single cell entirely on one page. When a layout containing a spreadsheet

is printed, the page division of the layout is used.
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Entering Text in the Heading of the Form
4. Enter the texts in the following example in the appropriate cells.

5. To set the various font sizes and bold typeface, use the Format

menu or the palette Windows>Palettes>Typography.

The text you enter in cells A1, A2, A6, E6, E10, and so on

may run across the cells to the right, since they will not contain any data.

This is different in the following part of the invoice.

Because the word �Account Number� is too long for the preset

column width, and the adjacent cell also contains data, the text appears

to be clipped at the cell border. RagTime has the text but does not show

it because there is no space.

6. Widen column E by dragging the dividing line after the column title E
to the right. The result should look like this:

7. Complete the next rows according to the example and widen the

columns as needed.
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B / A The spreadsheet layout often harmonizes better with the

paper size when in landscape mode. If necessary, switch the paper

orientation by choosing File>Page Setup...

A RagTime displays the Typography palette �docked� underneath the

other tool bars.

If you would like to position the Typography palette somewhere

else as shown in the adjacent illustration, grab the double-bar handle on

the left and drag the palette to your desired location.

You can also use a formula to calculate the invoice date in cell F20
either by choosing Edit>Insert Special Text>DocumentDate (short)

or by entering a formula. The DocumentDate function (see exercise 5) is

particularly well-suited for stationery pads.

You can use the command Format>Value Format>� to set the

value format for displaying cell contents.

Choosing Windows>Auxiliaries>Value Formats opens a

window that allows you to analyze and edit existing and create new value

formats. If you change the definition of a value format here, the change

will automatically be applied whenever the format is used. We

recommend you experiment with the formats and refer to the on-screen

documentation for details. We will address value formats in more depth

later on.
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Formatting the Headings
8. Align the contents of cells in rows 16 through 21 as shown in the

following illustration by choosing Format>Alignment>Centered/

Right.

We want to emphasize the headings in row 23 by making them bold

and colored.
9. Select row 23 by clicking the row header.

10. Click the Bold button in the Typography palette or choose

Format>Style>Bold.

11. Choose Format>Color>

(Gray).

The result should look

something like this:
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Entering and Formatting Invoice Items
12. Write the first invoice item in row 22.

13. Center the contents of cells A22 through C22 with Format>

Alignment>Centered.

Calculating Extended Amounts
14. Select cell F22.

15. Open the Formula palette by clicking the abacus in the tool bar and

click in the entry field of the palette to start entering the formula.
16. To enter the formula Shipped * Unit Price, click cell B22, type an

asterisk (*), and click cell E22. Complete the formula by pressing Enter

or �check it off.�

17. Enter additional invoice items according to the following example,

widening columns when necessary.

18. To center align the values in cells A23 to C50, select the range by

clicking in cell A25 and, while holding down the mouse button, dragging

the pointer to cell C50.
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B / A RagTime automatically recognizes a slew of value formats.

You can test this by typing "$0.85" in cell E24. RagTime interprets this as

the numeric value 0.85 connected to  the dollar currency format, as shown

in the menu bar. The entry is displayed with this link in layout mode.

A Formulas not only calculate all sorts of values, but handle text

operations as well. Let�s set up the following scenario: The customer

discount is to be stricken for advertising purposes. The customer�s

discount rate is extracted from a mail-merge file and entered into the

non-printing cell D19.

Several solutions are conceivable. They are listed below, beginning with

the easiest. Try them out and experiment with your own changes! The

text is to appear in cell A58. If you lighten the font color by choosing

Format>Tint>60%, the invoice form demands less obtrusive ad-

vertising.
Place the pointer in cell A58, click the Abacus, and enlarge the Formula

palette a little before getting to work in it. 

Please note that quotation marks must be entered as well!

> Simple link, albeit still including a rounding error:
Formula: "A customer discount of $ " & Text(F52) &
" has been granted!"

> Simple link, value format $ with two decimal places:
Formula: "A customer discount of " & Text(F52;value
format("Dollar")) & " has been granted!"

> The fields containing the applicable discount rate (D19) and the final

amount (F51) have been selected as reference quantities:

Formula: "A customer discount of " & Text(D19*F51/
100) & " $  has been granted!"
> Output only if the customer discount rate is greater than zero:
Formula: If(D19 > 0;"A customer discount of " &
Text(D19*F51/100) & " $ has been granted!";)

There is an empty operating instruction behind the last semicolon,

which is carried out (but has no effect!), if the expression D19 > 0 is

false. To finish up, reduce the font�s tint by choosing Format>Tint>

60%, as recommended above.
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19. Center the contents of cells A23 through C50.

20. Select cell E22 through F50 in the same way.

21. Give the cells the value format for dollars by choosing Format>

Value Format>$. Compare the illustration below with your results.

Copying Formulas
As you saw in exercise 3, you don�t have to enter the formula in F22

for calculating the extended amount separately in each cell. You can copy

it into the following cells.
22. Select cell F22 (containing the formula for calculating the extended

amount of item 1). 

23. Choose the command Edit>Copy from the menu bar.
24. Select cells F23 through F50.
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25. Choose Edit>Paste from the menu bar. The result should look like

this:

Hiding Zeros
Zeros appear in some cells because no unit prices or shipped

quantities have been entered in the corresponding lines. How to hide

these zeros is described in the following steps.

26. Select the corresponding range in column F and make sure it

remains highlighted. Choose Spreadsheet>Get Info from the menu

bar. The Spreadsheet Information dialog appears.

27. Select the panel Cell Contents.

28. Check Zero Values

Hidden and confirm the

change with OK.

The change appears

immediately:



Exercise 6: He Who Sells Must Write Bills 157  �  Notes
A Formulas can be copied quickly by using the fill-in feature. Or, you

may prefer the following option to the procedure described to the left.
1. Select cell F24 (containing the formula for calculating the extended

amount of item 1).

2. Drag the cell�s bottom handle to cell F30.

RagTime copies the formula together with cell F24�s fixed value format

to the selected cells and generates the desired results. (When in doubt,

you can verify the formula in the formula palette.) 
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The Lower Portion of the Invoice
29. Enter the necessary texts and numbers, according to the following

example, at the bottom of the invoice.

Cell F51 should contain the sum of the extended prices in column

F.
30. Select cell F51 and click the Functions icon in the tool bar.

31. Select the function Sum in the dialog box which opens and click

Insert. The Formula palette opens, displaying the Sum function. The

insertion marker blinks between the parentheses. 
32. Drag across cells F49:F22. RagTime sets the addresses between

the parentheses of the function.

33. Press Enter or �check off� the formula in the palette.

34. The next formula calculates the discount (in this example, 5.0 %).

Select cell F52.
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If you want to specify fixed deadlines from the date of the invoice in

cell F18 to the payment due date in cells F19, it makes sense to

calculate the latter using formulas, especially when working in forms. For

example, you can enter the formula F18 + 10 in cell F19. RagTime

then enters dates of 10 days after the invoice date.

As usual, you can set the date format under Format>Value

format>...
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35. Click in the Formula palette and enter the formula shown in the

illustration below.

36. The next formula calculates the net amount. Select cell F53.

37. Click in the Formula palette and enter the formula shown in the

illustration below.

38. Create formulas for cells F54 and F55 in the corresponding way.

39. The formatting still needs to be done. Select cells F51:F55 and

choose Format>Value Format>$.

40. Set the style of cells to bold according to the example.

Settings for the Cell Grid Lines and Cell Borders
The cell grid lines are mainly for orientation on the screen and are

normally not printed. As you saw in the

example at the beginning of this exer-

cise, the invoice is divided not with the

grid, but with individual, strategically

placed lines.

41. To turn off the grid lines, choose

Spreadsheet>Get Info.

42. Select the panel General and turn

off the check box for Cell Grid Lines.

Confirm the change by clicking OK.
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To edit several cells at once, you have thus far selected them with

the mouse by dragging across them. Consequently, the cells can only be

contiguous, or touching. You can enlarge or reduce such contiguous

selections with s+click.

If you want to concurrently edit a number of cells which are not

contiguous, you can select them with Ctrl+click and Ctrl+ drag. In the

exercise, you could select cells B51 and E55:F55 this way and set them

to Bold in one step.
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The work with the spreadsheet is complete. Further design is

simpler to conduct in the layout, which gives you a better general

impression of your document. To close the spreadsheet window, choose

File>Close. The layout of the invoice looks approximately like this:

43. To set a border, select the cells E16:F18.

44. Select Spreadsheet>Borders and the following dialog box

appears.
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A If you�re thinking of using the preceding invoice as a multi-page form

for invoices, RagTime�s Title Row function is just what you�re looking for.

Title rows and title columns are inserted at the beginning of all spread-

sheets that are linked through pipelines. In our example, the  Title Rows

ensure that the company�s logo appears in the first two rows of each page

of the invoice. There are two ways to obtain title rows and title columns:

a) Title Rows via the Contextual menu:
1. Select row titles 1 and 2.

2. Define the selection as a Title Row using the Contextual menu.

b) Title Rows via the Information dialog box:

1.Click on the

spreadhseet and

call up the

Information

dialog box.

2. As shown

here, define the

two topmost

rows as Title

Rows in the

General panel.

3. RagTime highlights the first two rows by giving the row titles a

different color and design.

4. Generate a new page by choosing Extras>Add Page.

5. Create a spreadsheet component and connect it to the spreadsheet

on page one using the Pipeline tool. RagTime duplicates the title rows

with the company logo from page 1 on page 2.

6. Continue the invoice form as appropriate using subsequent rows,

including an amount carried over from page 1, etc.

If you need more than 2 pages for your invoice, you can turn to page

6 to find out how to generate a flexible document format with the help of

a master layout.
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You can turn borders for

the selected cell on and off

by clicking the

corresponding check

boxes. If you click a name

in the list, you can edit the

line style in the right part

of the dialog box. The line style is illustrated under Example.

45. Check Outside Borders and confirm your change by clicking OK. 

You can quickly create the desired cell borders in other parts of the

invoice in a similar way. If a border does not appear as you had

imagined, choose Edit>Undo to restore the previous state.

Designing a Simple Company Logo
To conclude this exercise, you should create a simple logo for the

invoice. The company initials �GOS� should appear in the upper right

corner as a decoration. The drawing tool graphic text is particularly

appropriate for creating such small labels.

46. Click in the layout outside the spreadsheet. The drawing tools

appear in the tool bar.

47. Select the graphic text tool and click in the layout page.

48. Type the three letters. If necessary, you can enlarge the screen

display by choosing Windows>Display Scale>�.

49. Format the characters according to the

example and press Enter.

50. Move the pointer over the rotation handle in the middle of the

object. The pointer changes its appearance.

51. Hold down the mouse button and drag the

pointer slightly away from the middle until a ghost

rectangle appears, and you can rotate the object

freely.

52. Rotate the object as you wish and release the

mouse button.

53. Move the logo to the suggested place in the

invoice and adjust its position with the arrow keys, if necessary.
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The checkboxes in the list of the Cell Borders dialog box turn on

and off the borders of selected cells. Empty and checked boxes have the

usual meaning; a dash in the checkbox means that the corresponding

border is turned on in only some of the selected cells.

The line style of cell borders can be set separately for every border;

therefore, you must select the borders in the list for which you want to

change the settings. If you want to set the style of several borders

concurrently, select the corresponding lines in the list with s+click or

Ctrl+ click.

You can further modify

the logo (and of course all

other drawing objects) by

cropping and scaling.

To crop an object,

hold down the Ctrl key

and drag the upper or

lower middle handle horizontally

To scale an object, hold down the Ctrl key while dragging a left or

right middle handle. If you move the pointer past the middle of the

object, it will be mirrored. Experiment with the object. In case of an

�emergency,� choose Drawing>Transformation>Reset

Transformation. You can also use the other handles to crop or scale an

object. Use the corresponding handles and drag as you wish.
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Creating a RagTime Stationery Pad
To save the document as a RagTime stationery pad, proceed as in

exercise 5. First delete the variable data from the spreadsheet so that

copies you tear off from the pad are empty.

54. Select cells A8:A12 (the invoice�s address field), and press the

Delete key.
55. Proceed in the same way with the invoice items in A22:E50. The

extended price column F22:F50 should not be deleted because it

contains formulas.

56. Likewise delete the account number, the invoice number, and the

shipping and due dates in F16:F19.
57. Save the invoice as a stationery pad with File>Save As.
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There are several methods to make cells �disappear� in spread-

sheets. If you use the command Edit>Clear (the same as pressing the

Delete key), the values and formulas in the selected cells are deleted.

Formats such as background, font and so on are preserved and used

again when you enter data in the cell.

If you use Spreadsheet>Remove Cells, the complete cells,

including all contents and format, are removed, and other cells are

moved into their places. In a dialog box, you can specify whether the

other cells should be moved from the right, below or the planes behind.

Corresponding commands are available for rows, columns and

layers.

Further commands permit the insertion of cells, rows, columns and

planes. Refer to the on-screen reference and experiment.



5.4 Highlights from This Chapter

General
> A RagTime stationery pad is an �electronic form pad� from which

pages may be torn off as needed.

> A RagTime stationery pad may have any number of pages.

> The design and order of pages in a stationery pad is completely

flexible.

> A RagTime stationery pad is created by selecting the file type

�RagTime 5 Stationery Pad (*rtt)� in the Save As dialog box.

> Pipelines are connections between containers through which texts

or spreadsheet contents can flow from one container to the other.

> The pipeline tool is located in the tool bar.

Concerning Exercises 5 and 6
> Additional layout pages are created with Extras>Insert Page.

Documents that retain the standard rectangle automatically

generate new pages as soon as text spills over.

> Pipelines may be laid between containers on the same or on

different pages.

> The automatic addition of pages is controlled by pipelines and

circular pipelines.

> Copies can be torn from stationery pads with a double-click on the

stationery pad icon in the Windows environment or in the RagTime

Open Document dialog box.

> If a stationery pad is located in  folder �Stationery Pads�, the name

of the pad appears in the menu under File>New Beginning

With>(stationery pad name).

> The cell grid lines in a spreadsheet may be turned on and off for

screen and print in the panel Spreadsheet>Get Info>General.

> Cell borders may be set individually in the Cell Borders dialog box

which you can open with Spreadsheet>Borders.

> Drawing objects and their contents may be freely rotated, skewed

and scaled. 
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6.1 Creating a Master Layout

A layout characterizes the appearance of a document. It determines

the area of a page which will be printed. Layouts may consist of many

pages which all have the same structure. But they can also include pages

which perform special tasks.

A document might contain

> a first page, for example, a cover page,

> left and right pages for the table of contents,

> left and right pages with regions for headers and footers,

> a page with landscape format for statistics and so on,

> left and right pages for an index,

> left and right pages for a bibliography, and

> a last page.

RagTime can produce such a document also.

This Training Manual will not expect you to create such a complex

example. But after doing the exercises in this chapter, with the aid of the

on-screen documentation, you will be able to create documents of this

complexity. The instrument that RagTime provides is the Master Layout.

Before beginning the next exercise, you should have an idea what a

master layout is, how it works and what it can do.

So far, we�ve shown you how to use circular pipelines that auto-

matically append new pages with a customized header to accommodate

text overflow when designing a RagTime stationery pad for a business

letter. The circular pipeline�s mechanism is ideal for use in stationery

pads for such small documents that rarely consist of more than two or

three different pages and are also seldom revised. At that point, we did

not discuss revising documents.

Now in some cases, changes in a layout can play an important role,

for example, when you have to decide on a layout in the drafting process

and the final version has yet to be determined. If your layout consists of a

large number of pages, you are forced to change every single page

individually.

If, for example, 10, 20 or more pages are involved, of which the

structure must be changed or on which an additional container must be

placed, the work can be time-consuming and arduous.

6 STEP THREE: RAGTIME PROFESSIONAL
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RagTime�s concept for master pages provides a solution to the

problem. You can not only design very complex and diverse layouts with

many different pages, but also modify the pages conveniently.

What Is a Master Layout?
A RagTime document can be divided into three parts:

> a master layout with master pages;

> the layout pages which will eventually be printed; and

> additional components like texts, spreadsheets and so on.

A master layout consists of pages of which you determine the

number and design and which are then used as �templates� for the

structure of the actual pages.

Assume that you have 94 pages with text, pictures and graphs.

Because the first and last pages differ from those in between, you need

to design a master layout with three master pages. They will be used for

the cover page, the body pages and the back page:

Master Layout with 3 Master Pages

Master Page 1 Master Page 2 Master Page 3

Layout with 94 pages

Page 1 Page 2,3,�,93 Page 94
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RagTime should then use the first master page for the first page of

your layout, the second master page for the next 92 pages and the third

master page for the last page.

This basic idea of master pages can be applied to the complex

example described at the beginning of this chapter as well.

This feature alone represents an advance over the simple RagTime

document with a circular pipeline. Pages were added as needed, but

changes were troublesome.

Master layouts show their strength in such situations. Let�s look at

two examples.

Changes in the Design Stage
Assume that you have everything finished. Texts, pictures and

graphs are okay. Now you can relax. What you could still use, though, is

a wider margin for proofreader�s notes.

You can easily make this change by altering just the second page of

the master layout. You reduce the text container to create space for

handwritten notes in the right margin.

The result is that all the pages in the layout are changed

accordingly. Since additional pages are now required for the text, not

only are they inserted, but the previous page 94, the last page, is moved

to the end. When everything is done, you can set the correct margin in

the master layout again.

Changing Existing Layouts
Assume that you have been using a master layout for some time

now as a template for technical documentation or for teaching material

used in a company training program. These documents must be brought

up to date from time to time. New material may need to be produced, or

the old material may need to be printed in a new form.

As in the first case, you can change the master layout. When you

change any master layout page, all layout pages based on it are changed

accordingly.

In the following exercises, you will have the opportunity to get to

know some of the basic features of the master layout.

You will learn

> how to create a master layout,

> what significance the master layout has for the layout,

> how the master layout can be used for automatic page addition,

> how to make changes in a master layout, and

> how changes affect a layout.

Goals
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Changing Existing Layouts176
The first of the two following exercises deals with a master layout

consisting of two pages and a layout in which pages may be appended as

needed.

The second exercise presents a somewhat more complex case and

shows how changes on master pages affect layout pages.
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6.2 Exercise 7: Getting Your Prices in Form�a Price List

Exercise 7 uses a simply structured price list to demonstrate how a

RagTime master layout works.

In this exercise, you will learn

> how to create a master layout;

> how to create a price list in a spreadsheet;

> how to use spreadsheet cells as containers;

> how to install pictures in a spreadsheet;

> how to extend the price list with new pages; and

> how easy it is to make changes in the price list with the aid of

master pages.

The Structure of a Master Layout
The master layout consists of a cover page and a second page which

functions as a template for the the actual price list.

The first page contains a text; the second consists of a spreadsheet.

What is special about this spreadsheet is column C, which will

demonstrate that components can be installed in cells. The cells in

column C will later contain pictures.

The Steps to a Master Layout
The procedure for creating and using the master layout shown

above may be described in a few steps. We will treat each of the steps in

the following text.

Goals
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ave regularly
> Creating a master layout

> Adding pages

> Designing pages

> Specifying the contents types and their behavior on the

derived pages.

> Specifying the use of master pages

> Creating a layout component based on a master layout

Creating a Master Layout
1. Start RagTime if necessary. Choose File>New Beginning with>

Master Layout.

A master layout appears in a new window

and the tool bar contains the layout tools.

Notice that the page tag is centered over the

page.

Save the document with the name �Price List� and please remember

to save it regularly.

< S
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Adding a Page
2. Add a second page with the command

Extras>Add Page. The master layout

should then look like the illustration.

(Reduce the screen display with the

command Windows>Display Scale>�

if necessary.)

Designing the Page
You have now reached the stage which

is the most work in the design phase. You

must decide on the form and features of the

master layout so that it will later fulfill your

demands. The better the master layout is

adapted to the task now, the less you will

have to change later.

3. Draw a rectangle on the first master

page which fills the entire printable range

and preset the content type to Text .

4. Enter the text in the illustration and

format it accordingly. The text for this

master page is written here because in

this case, it should appear unchanged  in

the layout, that is, the actual price list.

Changes such as the date may also be

made in the master layout. However,

RagTime still permits changes in the

layout. However you decide, you keep

your freedom to modify the design.

5. Draw a rectangle on the second master page which fills the entire

printable range and preset the content type to Spreadsheet.

6. Next design the title of the price list as in the following illustration.
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If a component is displayed in a RagTime 5 window, the window�s

title bar consists of the document name as it appears in the Windows OS

and the component name. 

Windows displaying, for example, editors for style sheets, units, or

rulers have no component name in the title bar.

A The date that reflects the status of the list can of course be auto-

matically generated within a master layout as well. To generate the

current date, for example, place the pointer where you would like it to

appear, and choose Edit>Insert Special Text>Date Stamp (short).

The date functions can also be used to insert the current calendar week

and other date-related information using formulas.
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To enter the multiple-line titles of the price list, select

cells A1:E1. Click the multiline text button in the tool

bar. You can now enter multiple lines of text in a single cell.

You will find the commands for formatting text in the Format menu.

Pictures of the articles are to be later inserted in column C. To this

end, you must change the width and height of the affected cells. The

dimensions depend on the size of the pictures that you want to use. In

this example, the dimensions should be 2.75 inches * 1.75 inches.
7. Select cell C3 and choose Spreadsheet>Get Info. Select the

panel Arrangement and enter the width and height.

8. Confirm your changes

with OK; the cell assumes

the new dimensions.

9. You can set the height and width of several cells at once. Select cells
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You can also open the information dialog box for the selected

objects by clicking the �i� button in the tool bar.

Even if you have selected only one cell, settings for margins and cell

dimensions apply to the entire column or row: width, left and right

margins and the position for the decimal point apply to the entire

column; height, upper and lower margins and baseline position apply to

the entire row.

Orientation, alignment, and connection of contents and container

apply only to the selected cells.
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C4 through C7 and repeat the aforementioned steps. 

10. If a few rows remain at the bottom of the spreadsheet container,

reduce the size of the container by dragging the middle handle of the

lower border upwards. The result should look somewhat like this:

The set-up and formatting are completed. All the layout pages later

originating from this master page should have the same structure as this

spreadsheet. The contents of the spreadsheet cells should remain

editable, because you want to add various articles to the price list. You

can manage this by creating duplicate spreadsheet components on the

derived layout pages.
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B / A There are several ways of creating cells with the same height

below a list header if they don�t require a specific height.

1. Highlight cells A3 through E8 in a new spreadsheet.

2. Place the pointer on the row header exactly between the separator

lines of rows 8 and 9. The pointer changes in appearance.

3. Click and drag the pointer downward. As you can see, the heights of

rows 3 through 8 increase at the same rate. Your screen size and display

scale may require you to interrupt the procedure occasionally to scroll up

the bottom part of the window.
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11. Select the rectangle containing the spreadsheet and choose

Drawing>Get Info.

12. Select the Objects panel and choose the appropriate setting from

the pop-up menu Slave Options. Confirm your change with OK.

Determining When a Master Page Is Used
Now that you have designed both master pages, you have to assign

them their places in the layout. This is quickly done in this example.

First master page > The cover page has information about the

type and creation date of the price list.

Second master page > The pages for the price list, which follow the

cover page, are all based on this page.

13. To assign the cover page its position in the document, click the page

tag. The entire page is selected.
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In the unusual event that, on a layout page, you have to modify a

component which originates on a master page (but was not copied), you

can do so without changing any settings in the master layout. When you

attempt to make a change in the layout, the following warning appears

and you can create a duplicate for the particular case.

Changes which you later make in the corresponding component on

the master page cannot, of course, automatically be transmitted to this

layout page.

A When specifying modifications in the layout vis-à-vis the master

layout, one should determine whether these changes can be applied to

additional pages in the future. If so, you should modify the master

layout.

If the envisioned changes are to be applied to more than one page,

you might want to consider creating an additional page type in the

master layout.
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14. Now choose Layout>Get Info from the menu bar. 

15. Select the panel Master Pages. Name the master page �Cover

Page�.

You can specify a master page for various positions in later layouts:

for a particular page, as first or last page, according to a formula, or for

other cases.

16. For your cover page, click Whose Index Counted from the Start Is

Given and, since it is to be the first page, enter �1� in the entry field.

Confirm your changes with OK.

17. Select the second page by clicking the page tag.

18. Choose Layout>Get Info from the menu bar.

19. Name the second master page �Price list�.

20. It is to be used on pages To Which No Special Rule Applies.

Confirm your changes with OK.

Now you have defined the structure of your future price lists in a

master layout.

Creating a Layout Component Based on a Master Layout
Now you will produce the first price list.

21. Choose Windows>New Component>Layout. The New Layout

dialog box appears:

RagTime presents a list of

master layouts from which you can

choose one to be used for the new

layout. In our example, the list

contains only one master layout.
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You can open the information dialog box for layouts and master

layouts by double-clicking the page tag.

Your document now contains a number of components that RagTime

lists in the inventory. Open it by clicking Roderick the Squirrel in the tool

bar or with the command Windows>Palettes>Inventory.

If you like, you can leave it open and observe how components are

added in the course of the exercise. The components are sorted alpha-

betically in the inventory.

If necessary, enlarge the inventory�s

window using the window separator to

make its contents properly legible. To zoom

out the inventory, click the squirrel again or

click Close.

Should you have opened several documents

at the same time in RagTime, the inventory

displays all of these documents� com-

ponents indented underneath their respective names. You can flip these

lists open and shut using common Windows procedures.
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22. Click Select. The first page of a new layout component, a copy of

the cover page from the master layout, appears in a new window. Notice

that the tag displays the page number and the name of the master page

on which it is based.

23. Choose Extras>Add Page. The second page appears, a copy of the

price list page in the master layout. Notice here too that the page tag

includes the name that you gave the master page. You can append as

many pages as you need, according to the size of the price list. Pressing

Ctrl+E is faster than choosing a command from the menu.

Entering Data
You can now enter data in the price list. Start with the pictures for

the first five items. You can use your own TIFF, BMP, JPEG or similar

pictures on your PC. Use the Windows Explorer to transfer pictures.

24. Open the Windows Explorer and click Restore if the Explorer fills

your screen entirely.
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The new layout appears in the inven-

tory.

No new text component appears in the

inventory because the text component on

the first page of the layout is the same as

the one in the master layout.

The spreadsheet on the second page

of the master layout is set so that a dupli-

cate component is created on any layout

page based on the second master page.

Therefore, a second spreadsheet com-

ponent appears in the inventory after a

page is added to the layout.

When you drag a picture from the Scrapbook, that application

becomes active, and RagTime is in the background. However, RagTime

cannot display the dialog box until it is active again. You will hear the

system warning sound as a reminder to click in your RagTime document

again.
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25. Arrange the RagTime and Explorer windows so that the target

spreadsheet cell and the picture�s icon in the Explorer window are both

visible.

26. Drag the picture from the Explorer to the target cell in the price list.

Once the pointer crosses over into the RagTime window, it takes on a

different appearance indicating that a picture is being imported.

27. Repeat the �Drag & Drop� procedure with the other four pictures for

the price list.

28. Complete the price list by entering data in their corresponding

spreadsheet cells. If the description of an article is too long for the cell

width, click the MultilineText button. 

Modifying a Master Layout
Thus far, you have created a master layout for your price lists and

entered the appropriate data in a price list layout. Now you need to print

the list for others who must check if the information about each article

and the prices are correct. To assure that the list does not accidentally

wind up in the hands of customers, you want to mark all pages as drafts.

Some of the advantages of master layouts will now become apparent:

neither do you need to add a warning to each page, nor do you need to

go to the trouble of later removing individual warnings from the price list.

You change only the master page, and RagTime performs the same

change on every page based on it.
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After you insert the first picture, it

appears as a component in the inventory.

The names of the components are

assigned by RagTime, but of course you

can change them. Select a component in

the inventory by clicking it and change the

name as you would in the Windows

Explorer.

A With default settings, RagTime maintains a picture�s proportions

when importing it into RagTime documents. Since the size of the

container does not always match that of the picture, the picture

containers often have horizontal or vertical borders. There are several

ways of dealing with this situation.

1. Click the picture. The picture

tools appear in the tool bar.

2. Choose Picture>Fit

Container to Picture. This

makes the picture and container a

�perfect match.�

Please note that you can also

enter the picture�s scaling

manually in the Picture

Information>Arrangement

panel. This feature comes in handy

if you have to apply the same

scaling to a series of pictures.

You can also choose Pic-

ture>Aligin to align a picture.



Modifying a Master Layout196
29. Bring the window with the master layout to the front by clicking it. If

you cannot see it on the screen, choose Windows>Price List, Master

Layout 1 from the menu bar.

30. Click the second master page, �Price list,� somewhere outside the

spreadsheet. The tool bar contains the drawing tools.

31. Select the graphic text tool, click

approximately in the middle of the page,

and type �DRAFT�. Complete the input by

pressing the Enter key. The graphic text

object remains selected.

32. Choose Drawing>Get Info. Select

the Fill panel and choose Transparent

so that the object does not cover

everything. Now, all you need to do is

click Apply and you�re done.

33. Select the Typography panel.

Increase the font size to 144 point and

reduce the tint to 20%. Confirm your

changes with OK.

34. Rotate the text ap-

proximately 45°, so

that it runs from the

bottom left to the

upper right. You

master page should

look something like

this:

35. Bring the layout

window to the front by

clicking it. If you can-

not see it on the

screen, choose Win-

dows>Price List,

Layout 1 from the

menu bar. The new

graphic text has been

transferred to all

layout pages based on

the second master

layout page.
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To position the cell contents as you wish, experiment with the

horizontal and vertical placement features in the panel Arrangement in

the information dialog box.

If you have closed the master layout window in the meantime, open

it by opening the inventory and double-clicking the Master Layout  1

component.

When displaying width and height, RagTime conforms to standards

determined by the selected ruler or to the settings in the panel

Document in the dialog box opened by Extras>Document Settings.

Everywhere that you can enter measures of length, you can use all

defined units.

You can use the command Windows>Auxiliaries>Units to

determine which units are already defined and, as needed, define further

units. Experiment and refer to the on-screen reference.

A RagTime is also extremely versatile especially when it comes to

integrating pictures. Not only can you integrate numerous picture

formats (JPEG, TIFF, Pict, EPS, PNG, BMP, WMF/EMF, DCS, among others)

into your layout via drag and drop, you can now also place parts of

pictures in TIFF, EPS and JPEG format in transparent mode via clipping

paths in compliance with the Photoshop standard to produce new

effects. Try it out!

1. Create a clipping path for a TIFF, EPS or JPEG picture in Photoshop,

Corel Draw or a similar program.

2. Drag the picture icon from the desktop to a RagTime layout that

already contains other elements such as drawings or text.

3. RagTime conceals all picture components that are defined by the

clipping paths. Now might be the right time to experiment applying

various settings under Drawing>Stacking Order>... to the different

components in your layout. 

This gives your creativity in designing montages and unusual

layouts free reign!



Exercise 8: Company Training Is Necessary198
6.3 Exercise 8: Company Training Is Necessary

In this exercise, you will design a master layout which is appropriate

for many jobs. It can be used as the basis for a technical documentation

form, for reports of every sort or, as here, for teaching materials used in

company training.

The master layout can be easily adapted to your own ideas when

you use the techniques shown here in designing your own documents. 

The master layout should

provide templates for four

pages:

> a cover page;

> a left and a right page

for the body; and

> a last page with, for

example, conditions for

participation.
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Automatic Page Generation with a Master Layout
Automatic page generation with this master layout works as follows.

A layout based on this master layout consists of

> a cover page based on master page 1,

> any number of pages that are alternately based on the left and right

parts of master page 2, and

> the final page, which is based on master page 3, regardless if it is a

left or a right page.

The Steps to a Master Layout 
The procedure for creating and using the master layout described

above may be described in a few steps.

> Creating a master layout

> Creating pages

> Designing pages

> Specifying the use of master pages

> Drawing pipelines

> Creating a layout component based on a master layout

> Specifying the contents type of objects

> Using the layout

Creating a Master Layout
1. Choose Start>Programs>RagTime>RagTime or your favorite

method to start the program. Begin a new document with File>New

Beginning with>Master Layout. A master page appears in a new

window, and the tool bar contains layout tools.

Adding Pages
2. When you know how your master layout should be

constructed and how many differently structured pages

you will need, then create the appropriate number of

pages. Do this by choosing repeatedly Extras>Add Page

from the menu bar. You need two additional pages for our

example. For a better overview, choose Windows>

Display Scale>25% or 10%. The three page layout

should look like this illustration.
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Unlike pipelines in stationery pads, those in master layouts do not

determine which page is added when one is needed. The pipelines

determine only that an new page will be created in a layout. Which

master page will be used idepends on the settings in the Master Page

panel in the master layout information dialog box

In keeping with tradition, the right, or recto, pages are given odd

numbers, and the left, or verso, pages are given even.
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Designing the Pages
These three pages constitute the starting point for designing the

master layout. Using the appropriate tools, draw the objects on the

pages as shown in the illustration below.

3. Design the master layout according to your needs. The structure of

the three example master pages differ significantly from one another. We

have done this here only for the sake of the exercise, so that you can

later easily determine from which master page each layout page has

inherited its characteristics. 

4. A page number should appear to the lower right of the middle page.

Select the graphic text tool from the tool bar and click in the lower right

corner of the page.

5. Type the word �Page� and a blank space.

6. Choose Edit>Insert Special Text>Page Number. This will insert

the page number currently assigned to this master page. Page numbers

for subsequent layouts will be calculated and displayed automatically.

7. Move the text object containing the page number to the desired

position.
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Determining When a Master Page Is Used
8. To specify the use of the first master page,

select it by clicking the page tag.

9. Choose Layout>Get Info from the menu

bar. The following dialog box appears:

10. Select the Master Pages panel. Name the master page �Cover

page�.

11. Set Usage for the cover page to Whose Index Counted from the

Start Is Specified, and enter the number �1� in the formula entry field

since it is the first page. Confirm your changes with OK.

12. Select the second master page.

13. Choose Layout>Get Info from the menu bar.

14. Name the second master page �Body page�.

15. Set Usage to To Which No Special Rule Applies. Confirm your

changes with OK.

16. Select the third master page.

17. Choose Layout>Get Info from the menu bar.

18. Name the third master page �Final page�.

19. Set Usage for the final page to Whose Index Counted from the

End Is Specified, and enter the number �1� in the formula entry field
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You can open the information dialog box for layout and master

layout pages by double-clicking the page tag.

All master pages for which Usage is set to Whose Index Counted

from the Start (or End) Is Specified always appear in layouts based on

the corresponding master layout. When you delete such a page, it

reappears immediately.

If you use the same index number counted from the start (or end) for

several pages, only one of them will appear in layouts. You should avoid

this.

Should the layout derived from a master layout not meet your

expectations, verify that the rules set in the Layout Information>

Master Pages panel do not contradict one another.
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since it is the last page. Confirm your changes with OK.

20. Since you want the left and right pages to differ, click the page tag.

21. Choose Layout>Double-Sided Master Page.

RagTime creates a left page which is a mirror image of the right page

that you designed by moving the positions of the objects. Compare your

results with the illustration.

Installing Pipelines
Automatic page generation in layouts based on master layouts is

simpler than in stationery pads. You join the objects on the master pages

with pipelines and you are done.

22. Select the vertical pipeline tool from the tool bar.

23. Join the objects of the master layout as shown in the following

illustration.
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Creating a Layout
After you have finished the master layout for your pages, you can go

on to writing the text, making drawings, or making spreadsheets. You

need only to create a layout component.

24. Choose Windows>New Component>Layout from the menu bar.

The New Layout dialog box appears.

RagTime presents a list of master layouts from which you can

choose one to be used for the new layout. In our example, the list

contains only one master layout.

25. Click Select.
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Pipelines in master layouts obey somewhat different rules than

those in layouts or stationery pads.

In a layout, a pipeline directly connects the two objects between

which it was drawn. When the document is used as stationery, it is

exactly the same. In addition, you can draw circular pipelines across one

or more objects which serve to append pages automatically in

documents torn from stationery pads.

In master pages, on the other hand, pipelines determine that

something, for example text can flow into and out of an object. The

particular object that will be connected with a given object is first

determined when a layout is based on the master layout. Then, first

RagTime refers to the rules specified in the Master Page panel of the

information dialog to determine which pages must be created. Then

RagTime looks for pipeline entries and exits on neighboring pages and

connects these objects with each other.
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A layout appears with copies of all master

pages of which the usage is determined by the

index number from the start or end. In this case,

the cover and last pages appear.

Notice the page tags display the number of

the page in the layout and the names that you

assigned to the master pages.

The cover page has

the page number 1, an

odd number, so it is a

right page. The final page

has the number 2, an

even number, so it is a

left page. 

Determining the Contents Type of Drawing Objects
Thus far, you have not yet determined the contents of the drawing

objects, that is, which components should be installed in them. Assume

in this example that you will primarily need text.

26. Select the drawing object on the first page and choose Drawing>

Contents Type>Text.

Of course you can insert other components, for example a picture or

a spreadsheet, in the text if it is necessary at this place. Instead of text,

you could also begin with other contents.

Using the Layout and Master Layout
27. When you fill the drawing objects with, for example, text, the

appropriate pages are added as needed.

> The rectangle on the cover page is initially sufficient to contain the

entire text.

28. Continue to enter text until the space on the cover page is full.
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If you need a new page before the text overflows, you can use the

command Extras>Add Page at any time.
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> The cover page is no longer sufficient to

contain the entire text. The oval on the final page

is not connected with a pipeline, so the

overflowing text cannot flow to it. Then a new page

is created.

The new page 2 assumes the structure of

�Body page� of the master layout, which is

specified for all pages to which no special rule

applies.

The page has an even

page number, so the left

part of the body page is

used. The final page is

moved to the third position,

so it is now a right page. 

29. Continue adding

text until an additional

page is filled.

> Another page is

needed. The rules from

the master pages �Cover

page� and �Final page�

still apply to the first and

last pages of the layout.

The new page assumes

the structure of the

second master page,

which is specified for all

pages to which no special

rule applies.

The new page is page three of the layout, so the right page part of

the second master page is used. The final page is now page four, so it

becomes a left page.

If you continue to add text or create new pages in another way, the

new pages will alternately assume the structure of the left and right parts

of the master page �Body page.�
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If, for example, the text overflows in an object which is connected

with pipelines originating in a master layout, a new page is created.

Which master page will be used is specified in the master layout. If this

page does not have any object with a pipeline through which the text can

flow, another new page is created. To prevent this from happening

perpetually, after a while a dialog box will point this out to you and you

can terminate the automatic page creation.
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6.4 Highlights from This Chapter

General
> A RagTime document may include one or more master layouts and

layouts.

> A layout consists of one or more pages on which containers for

components are visible.

> A master layout serves as a pattern for an entire or a part of a

layout.

> A master layout consists of master pages which influence layout

pages like templates.

> A dynamic connection exists between master pages and layout

pages. If the master page is changed, the dependent pages in the

layout change accordingly.

> Automatic page generation in a layout is controlled by the master

layout.

> The mechanism of automatic page generation can be very precisely

controlled through settings in the master layout.

Concerning Exercises 7 and 8 
> The command File>New Beginning with>Master Layout begins

a new document with a master layout.

> Pipelines can be laid in both master layouts and layouts.

> Pages in a master layout are constructed in the same way and with

the same tools as pages in a layout. 

> Data (text, pictures and so on) which should be included unchanged

in the layout should be added in the master layout.

> Spreadsheets can contain other components, for example, pictures.

> A  layout is created with the command Windows>New

Component>Layout. At that point, you can link the layout to a

master layout.

> The  initial settings of the master layout can be adapted in layouts to

the respective requirements.
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The structure of a sample RagTime 5 document

The master layout structures the layout

The layout containes pages

Additional
master
layouts

Style sheets
and other
auxiliaries

structure 
formats

A document contains components
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In this training manual, we wanted to help you get acquainted with

RagTime 5. We hope that we were successful.

Space limitations prevented us from comprehensively familiarizing

you with all the features of the program. We could only support you in

your first efforts as a RagTime novice. Perhaps you have nevertheless

sensed the great potential waiting in RagTime, and it remains up to you

to discover it.

In the following three steps, you made a start with RagTime:

> the RagTime one-page document,

> the RagTime stationery pad,

> the RagTime master layout.

The following overview summarizes once more the most important

aspects of these three types of RagTime documents.

Please note that RagTime always offers several means to the same

goal. The procedures presented here must not necessarily reflect your

own ideas or methods. Should this be the case, modify them without

concern and make RagTime your personal tool.

The One-Page Document

Characteristics
> consists of one page

> has an arbitrary structure

> is relatively simple

Situation
> must be produced quickly

> minimal time for planning is available

> flexibility is of secondary importance

Examples
> mostly documents produced under pressure, such as one-time-only

letters, memos, calculations or statistics with graphic representation

Procedure
> create a layout component

> design the page

> define contents types

> use, save and print the layout component (document)

7 LOOKING FORWARD
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The RagTime Stationery Pad

Characteristics
> consists of an arbitrary number of pages 

> is highly structured 

> is moderately complicated

Situation
> must be produced quickly

> moderate time for planning is available

> flexibility is of secondary importance

Examples
> mostly standardized, reusable documents (stationery pads), such as

business letters with several pages, bids, invoices, payment

requests, or standard contracts

Procedure
> create a layout component

> append pages

> design the pages

> define contents types

> save the document as stationery

> tear off pages from the stationery pad, complete, save and print

them

The RagTime Master Layout

Characteristics
> consists of an arbitrary number of pages

> is highly structured 

> complexity is arbitrary, but usually relatively high

Situation
> relatively simple to create

> time is available for moderate to intensive planning

> easy modification is of primary importance

Examples
> appropriate for all sorts of documents

Procedure
> create a master layout component

> append pages

> design the pages

> define contents types

> define the use of the layout pages

> create layout components based on the master layout

> use, save and print the layout components (document)
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Where to Go From Here
Now that you have completed the training, we recommend that you

explore the on-screen help with specific questions in mind. You will find

on-screen help in Info menu. Here you will find detailed information

about RagTime 5�s features. 

Organized under the key expressions, program features which were

briefly mentioned or could not be treated in the training manual are

concisely explained.

It can likewise be interesting to examine finished documents.

Examine the numerous examples supplied with RagTime and modify

them according to your needs.

The most important recommendation that we can give you for

further work with RagTime is experiment!

Don�t be afraid to try things out in the program. Save a file, for

example from one of the exercises in this book or from the installation

CD, under another name and systematically try out all possible parts of

the program on this file. Here are a few suggestions for your

experiments:

> Experiment with the panels of the information dialog boxes. Choose

one after the other: Drawing>Get Info, Text>Get Info,

Spreadsheet>Get Info, Button>Get Info, and so on.

> Experiment with the panels in the Document Settings and

Settings dialog boxes.

Choose Extras>Document Preferences, and Extras>Settings.

> Find out how the program reacts to a double click in various places.

> Find out which menus you can tear off and position them as palettes

in convenient places on the screen.

> Find out which methods of dragging or duplicating data RagTime

supports within and between documents.

key words : > copy or cut and paste

> duplicate, for example, drawing objects or

containers using keyboard shortcuts

> duplicate, for example, drawing objects or

containers by dragging (Ctrl+drag object)

> drag and drop

> import and export

> Find out how style sheets can simplify your work. Choose

Windows>Auxiliaries.

> Experiment with the command Search and Replace. You will find it

in the Edit menu. You can also search for formats!

Explore  the 
on-screen help

Examine the 
example documents

Experiment with
RagTime

Information dialog
box

Document Settings
Settings

Double click

Tear off menus

Style sheets
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> If you have a scanner, find out what features RagTime 5 offers

(File>Scanners and Cameras...).

Surf by our Web pages (www.ragtime-online.com) from time to time.

This is where we post program improvements, sample solutions and

documents, information on new releases, related RagTime products,

existing mailing lists and dictionaries in various languages. The tidbits

we upload to our server are usually yours for free!

We hope you have fun with this brief selection of suggestions and

hope that when working with RagTime, you always reach your goals

along the shortest and fastest way. 

WWW server
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